Read the docs

Protection mechanism failure in Jenkins Script Security Plugin

Priority MEDIUM 56CWE-693Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 8 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-693.

Summary

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.50 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

Why it matters now

EPSS 0.19538 97th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:script-security (Maven): 1.51Red Hat: 1 advisoryRed Hat: 1 fixed, 8 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Script Security Pluginup to 1.50—No fix listedCNA
—org.jenkins-ci.plugins:script-security (Maven)before 1.511.51Patch availableGHSA-x5jm-rj37-5qh7
  • Jenkins Script Security Plugin VendorJenkins Affected up to 1.50 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.51 Fixed in 1.51 Patch available GHSA-x5jm-rj37-5qh7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:*up to 1.50VulnerableJenkins
  • cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:* Versions up to 1.50 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-x5jm-rj37-5qh7 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.51 Advisory →

Red Hat 1 advisory

  • RHSA-2019:0739 Released 2019-04-10 · Red Hat rating Important
    Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1552336312-1.el7

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.2AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.3AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.4AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.5AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.6AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.7AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.9AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.11Fixed RHSA-2019:0739
Not affected: 1 product
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003005
  2. 2026-10-03 Alias added: GHSA-x5jm-rj37-5qh7

References

  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
  • TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
  • TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
  • TI-2020-02156 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
See all 44 →

Sources