Code injection in Jenkins Script Security Plugin
Priority MEDIUM 48CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 3 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.64 and earlier related to the handling of default parameter expressions in constructors allowed attackers to execute arbitrary code in sandboxed scripts.
Why it matters now
EPSS 0.0275 86th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:script-security (Maven): 1.65Red Hat: 3 advisoriesRed Hat: 3 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Script Security Plugin | up to 1.64 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.65 | 1.65 | Patch available | GHSA-72gx-qq2m-6xr2 |
- Jenkins Script Security Plugin VendorJenkins Affected up to 1.64 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.65 Fixed in 1.65 Patch available GHSA-72gx-qq2m-6xr2
Remediation
- Fix · GHSA-72gx-qq2m-6xr2 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.65 Advisory →
Red Hat 3 advisories
- RHSA-2019:4089 Released 2019-12-17 · Red Hat rating ImportantOpenShift Container Platform 4.1 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins-4.1.1574872364-1.el7
- RHSA-2019:4055 Released 2019-12-16 · Red Hat rating ImportantOpenShift Container Platform 3.11 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1575261255-1.el7
- RHSA-2019:4097 Released 2019-12-11 · Red Hat rating ImportantOpenShift Container Platform 4.2 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 4.2 jenkins-2-plugins-4.2.1574873592-1.el7
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:4055 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2019:4089 |
| Red Hat OpenShift Container Platform 4.2 | Fixed | RHSA-2019:4097 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10431
- 2026-10-03 Alias added: GHSA-72gx-qq2m-6xr2
References
Advisory 6
More Jenkins Script Security vulnerabilities
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
- TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2020-02156 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2019-10431 · CVE Program
- CVE-2019-10431 · NVD
- FIRST EPSS
- GHSA-72gx-qq2m-6xr2 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10431 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences