Read the docs

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows…

Priority MEDIUM 48CWE-470Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 6 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows attackers to invoke arbitrary constructors in sandboxed scripts.

Why it matters now

EPSS 0.03431 89th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:script-security (Maven): 1.56Red Hat: 1 advisoryRed Hat: 1 fixed, 6 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Script Security Pluginup to 1.55—No fix listedCNA
—org.jenkins-ci.plugins:script-security (Maven)before 1.561.56Patch availableGHSA-3pv3-jj4h-p528
  • Jenkins Script Security Plugin VendorJenkins Affected up to 1.55 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.56 Fixed in 1.56 Patch available GHSA-3pv3-jj4h-p528

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:*up to 1.55VulnerableJenkins
cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*3.11VulnerableRed Hat
  • cpe:2.3:a:jenkins:script_security:*:*:*:*:*:jenkins:*:* Versions up to 1.55 Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-3pv3-jj4h-p528 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.56 Advisory →

Red Hat 1 advisory

  • RHSA-2019:1423 Released 2019-06-10 · Red Hat rating Important
    Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1553788831-1.el7

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.4AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.5AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.6AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.7AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.9AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.11Fixed RHSA-2019:1423
Not affected: 1 product
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003040
  2. 2026-10-03 Alias added: GHSA-3pv3-jj4h-p528

References

  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
  • TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
  • TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
  • TI-2020-02156 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
See all 44 →

Sources