An issue was discovered in SmtpTransport in CakePHP 3.7.6.
Priority LOW 37CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
An issue was discovered in SmtpTransport in CakePHP 3.7.6. An unserialized object with modified internal properties can trigger arbitrary file overwriting upon destruction.
Why it matters now
EPSS 0.02002 80th percentileScored 2026-11-07
Fix Fixed cakephp/cakephp (Packagist): 3.5.18, 3.6.15, 3.7.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cakephp/cakephp (Packagist) | 3.0.0 to before 3.5.18 | 3.5.18 | Patch available | GHSA-qhrx-hcm6-pmrw |
| — | cakephp/cakephp (Packagist) | 3.6.0 to before 3.6.15 | 3.6.15 | Patch available | GHSA-qhrx-hcm6-pmrw |
| — | cakephp/cakephp (Packagist) | 3.7.0 to before 3.7.7 | 3.7.7 | Patch available | GHSA-qhrx-hcm6-pmrw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cakephp/cakephp (Packagist) Vendor— Affected 3.0.0 to before 3.5.18 Fixed in 3.5.18 Patch available GHSA-qhrx-hcm6-pmrw
- cakephp/cakephp (Packagist) Vendor— Affected 3.6.0 to before 3.6.15 Fixed in 3.6.15 Patch available GHSA-qhrx-hcm6-pmrw
- cakephp/cakephp (Packagist) Vendor— Affected 3.7.0 to before 3.7.7 Fixed in 3.7.7 Patch available GHSA-qhrx-hcm6-pmrw
Remediation
- Fix · GHSA-qhrx-hcm6-pmrw cakephp/cakephp (Packagist) Fixed in 3.5.18 Advisory →
- Fix · GHSA-qhrx-hcm6-pmrw cakephp/cakephp (Packagist) Fixed in 3.6.15 Advisory →
- Fix · GHSA-qhrx-hcm6-pmrw cakephp/cakephp (Packagist) Fixed in 3.7.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11458
- 2026-10-03 Alias added: GHSA-qhrx-hcm6-pmrw
References
Patch 3
Advisory 3
Other 4
More Cakephp vulnerabilities
- TI-2010-04068 The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x… CVSS 2.0HIGH 7.5
- TI-2026-19037 CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting CVSS 3.1MEDIUM 5.4
- TI-2023-08901 Database Query::offset() and limit() vulnerable to SQL injection in cakephp CVSS 3.1CRITICAL 9.8
- TI-2016-04142 The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their… CVSS 3.0HIGH 7.5
- TI-2015-06899 CakePHP 2.x and 3.x before 3.1.5 might allow remote attackers to bypass the CSRF… CVSS 3.0HIGH 8.8
- TI-2020-17913 A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. CVSS 3.1HIGH 8.8
Sources
- CVE-2019-11458 · CVE Program
- CVE-2019-11458 · NVD
- FIRST EPSS
- GHSA-qhrx-hcm6-pmrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences