Priority MEDIUM 64
transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before 1.18.5, 2.0.x before 2.0.8, 2.1.x before 2.1.5, 2.2.x before 2.2.3, 2.3.x before 2.3.2, and 2.4.x before 2.4.1 does not properly chec…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.27105 · Published 2018-03-13 · Partial fix · 2.0.8, 2.1.5 +5 CWE-287
Priority MEDIUM 50
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04743 · Published 2018-07-19 · Partial fix · 2.3.1.0, 2.1.6.0 +1 CWE-20
Priority LOW 37
A flaw was found in the Ansible Engine 2.9.18, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02043 · Published 2021-04-29 · Partial fix · 2.10.6rc1, 2.9.18rc1 +1 CWE-200
Priority LOW 35
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that…
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00509 · Published 2019-10-08 · Partial fix · 2.6.20, 2.7.14 +1 CWE-117
Priority LOW 35
A flaw was found in ansible.
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00587 · Published 2018-07-13 · Partial fix · 2.4.6.0, 2.5.6 +1 CWE-426
Priority LOW 35
In ansible it was found that inventory variables are loaded from current working directory when running ad-hoc command which are under attacker's control, allowing to run arbitrary code as a result.
CVSS 3.0HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00485 · Published 2018-07-02 · Partial fix · 2.4.6.0, 2.5.6 +1 CWE-426
Priority LOW 34
A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination…
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00365 · Published 2020-03-09 · Partial fix · 2.8.9, 2.9.6 +1 CWE-22
Priority LOW 34
Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen.
CVSS 3.0HIGH 7.8· Local · No auth · User interaction · EPSS 0.00362 · Published 2018-10-23 · Partial fix · 2.7.1, 2.6.7 +1 CWE-214
Priority LOW 33
A flaw was found in Ansible, where a user's controller is vulnerable to template injection.
CVSS 3.1HIGH 7.1· Local · Low privileges · No interaction · EPSS 0.00897 · Published 2021-09-22 · Partial fix · 2.9.23rc1, 2.10.11rc1 +1 CWE-20
Priority LOW 33
A flaw was found in the pipe lookup plugin of ansible.
CVSS 3.1HIGH 7.4· Local · Low privileges · User interaction · EPSS 0.00455 · Published 2020-03-03 · Partial fix · 2.10.0rc1, 2.9.11 +1 CWE-78
Priority LOW 32
Ansible 2.5 prior to 2.5.5, and 2.4 prior to 2.4.5, do not honor the no_log task flag for failed tasks.
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.03088 · Published 2018-07-02 · Partial fix · 2.5.5, 2.4.5.0 CWE-532
Priority LOW 31
A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module.
CVSS 3.1HIGH 7.1· Local · Low privileges · No interaction · EPSS 0.00233 · Published 2020-09-23 · Partial fix · 2.8.15, 2.9.13 CWE-347
Priority LOW 29
ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.
CVSS 3.1MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.02462 · Published 2019-01-03 · Partial fix · 2.5.14, 2.6.11 +1 CWE-200
Priority LOW 26
An Improper Output Neutralization for Logs flaw was found in Ansible when using the uri module, where sensitive data is exposed to content and json output.
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00573 · Published 2020-09-11 · Partial fix · 2.10.0 CWE-532
Priority LOW 26
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on…
CVSS 3.1MEDIUM 5.6· Local · High privileges · No interaction · EPSS 0.00713 · Published 2020-03-31 · Partial fix · 2.9.3, 2.8.8 +1 CWE-20
Priority LOW 25
A flaw was found in Ansible Engine's ansible-connection module, where sensitive information such as the Ansible user credentials is disclosed by default in the traceback error message.
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.0039 · Published 2022-03-03 · Partial fix · 2.9.27 CWE-209
Priority LOW 25
A flaw was found in the Ansible Engine when using module_args.
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00407 · Published 2020-09-11 · Partial fix · 2.8.14, 2.9.12 +1 CWE-117
Priority LOW 25
A flaw was found in the use of insufficiently random values in Ansible.
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00435 · Published 2021-05-27 · Fixed in 2.9.6 CWE-330
Priority LOW 25
A flaw was found in Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 whe…
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00361 · Published 2020-05-11 · Partial fix · 2.7.17, 2.8.11 +1 CWE-459
Priority LOW 25
A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all Ansible 2.9.x versions prior to 2.9.7, when managing kubernetes using the k8s mo…
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00506 · Published 2020-03-16 · Partial fix · 2.7.18, 2.8.12 +1 CWE-200
Priority LOW 25
A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5.
CVSS 3.1MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00424 · Published 2019-10-14 · Partial fix · 2.9.0rc4, 2.8.6 +2 CWE-117
Priority LOW 25
An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances.
CVSS 3.1MEDIUM 4.9· Network · High privileges · No interaction · EPSS 0.0144 · Published 2018-07-26 · Partial fix · 2.2.1.0 CWE-20
Priority LOW 23
An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install.
CVSS 3.1MEDIUM 5.2· Local · Low privileges · No interaction · EPSS 0.00303 · Published 2020-04-30 · Fixed in 2.9.7 CWE-22
Priority LOW 23
A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3…
CVSS 3.1MEDIUM 5.0· Local · Low privileges · User interaction · EPSS 0.0039 · Published 2020-05-12 · Partial fix · 2.8.11, 2.9.7 +1 CWE-200
Priority LOW 21
Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext.
CVSS 3.0MEDIUM 4.4· Local · High privileges · No interaction · EPSS 0.00535 · Published 2018-11-29 · Partial fix · 2.7.3, 2.5.12 +1 CWE-532