Apache OpenMeetings before 3.1.2 is vulnerable to Remote Code Execution via RMI deserialization attack.
Priority MEDIUM 50CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Apache OpenMeetings before 3.1.2 is vulnerable to Remote Code Execution via RMI deserialization attack.
Why it matters now
EPSS 0.04781 91st percentileScored 2026-11-07
Fix Fixed Apache OpenMeetings (Apache Software Foundation): 3.1.12org.apache.openmeetings:openmeetings-parent (Maven): 3.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache OpenMeetings | before 3.1.12 | 3.1.12 | Patch available | CNA |
| — | org.apache.openmeetings:openmeetings-parent (Maven) | before 3.1.2 | 3.1.2 | Patch available | GHSA-6cpg-3w7f-j67q |
- Apache OpenMeetings VendorApache Affected before 3.1.12 Fixed in 3.1.12 Patch available CNA
- org.apache.openmeetings:openmeetings-parent (Maven) Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available GHSA-6cpg-3w7f-j67q
Remediation
- Fix · CNA Apache OpenMeetings (Apache Software Foundation) Fixed in 3.1.12
- Fix · GHSA-6cpg-3w7f-j67q org.apache.openmeetings:openmeetings-parent (Maven) Fixed in 3.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8736
- 2026-10-03 Alias added: GHSA-6cpg-3w7f-j67q
References
Advisory 2
More Apache Openmeetings vulnerabilities
- TI-2024-36639 Apache OpenMeetings: Deserialisation of untrusted data in cluster mode CVSS 3.1CRITICAL 9.8
- TI-2026-26346 Apache OpenMeetings: Login Credentials Passed via GET Query Parameters CVSS 3.1HIGH 7.5
- TI-2020-10927 Attackers can use public NetTest web service of Apache OpenMeetings 4.0.0-5.0.0 to organize denial of service attack. CVSS 3.1HIGH 7.5
- TI-2016-00702 Directory traversal vulnerability in the Import/Export System Backups functionality in… CVSS 3.0MEDIUM 6.5
- TI-2023-12874 Apache OpenMeetings: allows user impersonation CVSS 3.1CRITICAL 9.8
- TI-2017-05300 Uploaded XML documents were not correctly validated in Apache OpenMeetings 3.1.0. CVSS 3.0CRITICAL 10.0
Sources
- CVE-2016-8736 · CVE Program
- CVE-2016-8736 · NVD
- FIRST EPSS
- GHSA-6cpg-3w7f-j67q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences