Commit metadata forgery via CGI::FormBuilder context-dependent APIs
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
ikiwiki before 3.20161229 incorrectly called the CGI::FormBuilder->field method (similar to the CGI->param API that led to Bugzilla's CVE-2014-1572), which can be abused to lead to commit metadata forgery.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ikiwiki | ikiwiki | before 3.20161229 | 3.20161229 | Patch available | CNA |
- ikiwiki Vendorikiwiki Affected before 3.20161229 Fixed in 3.20161229 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ikiwiki:ikiwiki:*:*:*:*:*:*:*:* | before 3.20161229 | Vulnerable | ikiwiki |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:ikiwiki:ikiwiki:*:*:*:*:*:*:*:* Versions before 3.20161229 Vulnerable ·ikiwiki
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA ikiwiki (ikiwiki) Fixed in 3.20161229
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
ikiwiki — DSA-3760
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2017-00331 Authentication bypass via repeated parametersPriority MEDIUM 48
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9646
- 2026-10-03 Alias added: GHSA-fvvm-x83v-fc5r
References
More Ikiwiki vulnerabilities
- TI-2017-00331 Authentication bypass via repeated parameters CVSS 3.0CRITICAL 9.8
- TI-2011-01233 ikiwiki before 3.20110608 allows remote attackers to hijack root's tty and run symlink attacks. CVSS 3.1HIGH 8.2
- TI-2016-08112 ikiwiki 3.20161219 does not properly check if a revision changes the access permissions… CVSS 3.0HIGH 7.5
- TI-2019-06647 ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the… CVSS 3.0HIGH 7.5
- TI-2008-00155 Plugin/passwordauth.pm (aka the passwordauth plugin) in ikiwiki 1.34 through 2.47 allows… CVSS 2.0MEDIUM 6.8
- TI-2016-07849 Editing restriction bypass for git revert CVSS 3.0MEDIUM 6.5
Sources
- CVE-2016-9646 · CVE Program
- CVE-2016-9646 · NVD
- FIRST EPSS
- GHSA-fvvm-x83v-fc5r · GitHub Advisory Database · CC BY 4.0
- CVE-2016-9646 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences