Read the docs
TI-2016-08564 Aliases CVE-2016-10522GHSA-pxqr-8v54-m2hj

Cross-site request forgery in https://github.com/sferik rails_admin ruby gem

Priority MEDIUM 40CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks. Non-GET methods were not validating CSRF tokens and, as a result, an attacker could hypothetically gain access to the application administrative endpoints exposed by the gem.

Why it matters now

EPSS 0.00983 62nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed rails_admin (RubyGems): 1.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
https://github.com/sferikrails_admin ruby gem>= 1.1.1—No fix listedCNA
—rails_admin (RubyGems)1.0.0 to before 1.1.11.1.1Patch availableGHSA-pxqr-8v54-m2hj
  • rails_admin ruby gem Vendorhttps://github.com/sferik Affected >= 1.1.1 Fixed in — No fix listed CNA
  • rails_admin (RubyGems) Vendor— Affected 1.0.0 to before 1.1.1 Fixed in 1.1.1 Patch available GHSA-pxqr-8v54-m2hj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rails_admin_project:rails_admin:*:*:*:*:*:ruby:*:*before 1.1.1VulnerableRails Admin Project
  • cpe:2.3:a:rails_admin_project:rails_admin:*:*:*:*:*:ruby:*:* Versions before 1.1.1 Vulnerable ·Rails Admin Project

Remediation

  • Fix · GHSA-pxqr-8v54-m2hj rails_admin (RubyGems) Fixed in 1.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-10522
  2. 2026-10-03 Alias added: GHSA-pxqr-8v54-m2hj

References

  • TI-2020-18510 RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms. CVSS 3.1MEDIUM 6.1
  • TI-2017-08891 An exploitable cross site scripting (XSS) vulnerability exists in the add filter… CVSS 3.1MEDIUM 6.1
  • TI-2024-26264 RailsAdmin Cross-site Scripting vulnerability in the list view CVSS 3.1MEDIUM 5.4

Sources