RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.
Why it matters now
EPSS 0.01294 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed rails_admin (RubyGems): 1.4.3, 2.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | rails_admin (RubyGems) | before 1.4.3 | 1.4.3 | Patch available | GHSA-wjx2-7hqq-8h7m |
| — | rails_admin (RubyGems) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-wjx2-7hqq-8h7m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- rails_admin (RubyGems) Vendor— Affected before 1.4.3 Fixed in 1.4.3 Patch available GHSA-wjx2-7hqq-8h7m
- rails_admin (RubyGems) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-wjx2-7hqq-8h7m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rails_admin_project:rails_admin:*:*:*:*:*:ruby:*:* | before 1.4.3; 2.0.0 to before 2.0.2 | Vulnerable | Rails Admin Project |
- cpe:2.3:a:rails_admin_project:rails_admin:*:*:*:*:*:ruby:*:* Versions before 1.4.3; 2.0.0 to before 2.0.2 Vulnerable ·Rails Admin Project
Remediation
- Fix · GHSA-wjx2-7hqq-8h7m rails_admin (RubyGems) Fixed in 1.4.3 Advisory →
- Fix · GHSA-wjx2-7hqq-8h7m rails_admin (RubyGems) Fixed in 2.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-36190
- 2026-10-03 Alias added: GHSA-wjx2-7hqq-8h7m
References
Patch 2
More Rails Admin Project Rails Admin vulnerabilities
- TI-2016-08564 Cross-site request forgery in https://github.com/sferik rails_admin ruby gem CVSS 3.0HIGH 8.8
- TI-2017-08891 An exploitable cross site scripting (XSS) vulnerability exists in the add filter… CVSS 3.1MEDIUM 6.1
- TI-2024-26264 RailsAdmin Cross-site Scripting vulnerability in the list view CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-36190 · CVE Program
- CVE-2020-36190 · NVD
- FIRST EPSS
- GHSA-wjx2-7hqq-8h7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences