Read the docs
TI-2017-08891 Aliases CVE-2017-12098GHSA-pxr8-w3jq-rcwj

An exploitable cross site scripting (XSS) vulnerability exists in the add filter…

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

An exploitable cross site scripting (XSS) vulnerability exists in the add filter functionality of the rails_admin rails gem version 1.2.0. A specially crafted URL can cause an XSS flaw resulting in an attacker being able to execute arbitrary javascript on the victim's browser. An attacker can phish an authenticated user to trigger this vulnerability.

Why it matters now

EPSS 0.01279 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed rails_admin (RubyGems): 1.3.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—rails_admin (RubyGems)before 1.3.01.3.0Patch availableGHSA-pxr8-w3jq-rcwj
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • rails_admin (RubyGems) Vendor— Affected before 1.3.0 Fixed in 1.3.0 Patch available GHSA-pxr8-w3jq-rcwj

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rails_admin_project:rails_admin:1.2.0:*:*:*:*:ruby:*:*1.2.0VulnerableRails Admin Project
  • cpe:2.3:a:rails_admin_project:rails_admin:1.2.0:*:*:*:*:ruby:*:* Versions 1.2.0 Vulnerable ·Rails Admin Project

Remediation

  • Fix · GHSA-pxr8-w3jq-rcwj rails_admin (RubyGems) Fixed in 1.3.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-12098
  2. 2026-10-03 Alias added: GHSA-pxr8-w3jq-rcwj

References

  • TI-2016-08564 Cross-site request forgery in https://github.com/sferik rails_admin ruby gem CVSS 3.0HIGH 8.8
  • TI-2020-18510 RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms. CVSS 3.1MEDIUM 6.1
  • TI-2024-26264 RailsAdmin Cross-site Scripting vulnerability in the list view CVSS 3.1MEDIUM 5.4

Sources