RailsAdmin Cross-site Scripting vulnerability in the list view
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00579 47th percentileScored 2026-11-07
Fix Fixed rails_admin (railsadminteam): 3.1.3, 2.3.0rails_admin (RubyGems): 3.1.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| railsadminteam | rails_admin | 3.0.0 to before 3.1.3; before 2.3.0 | 3.1.3, 2.3.0 | Patch available | CNA |
| — | rails_admin (RubyGems) | 3.0.0.beta to before 3.1.3 | 3.1.3 | Patch available | GHSA-8qgm-g2vv-vwvc |
- rails_admin Vendorrailsadminteam Affected 3.0.0 to before 3.1.3; before 2.3.0 Fixed in 3.1.3, 2.3.0 Patch available CNA
- rails_admin (RubyGems) Vendor— Affected 3.0.0.beta to before 3.1.3 Fixed in 3.1.3 Patch available GHSA-8qgm-g2vv-vwvc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rails_admin_project:rails_admin:*:*:*:*:*:ruby:*:* | before 2.3.0; 3.0.0 to before 3.1.3 | Vulnerable | Rails Admin Project |
- cpe:2.3:a:rails_admin_project:rails_admin:*:*:*:*:*:ruby:*:* Versions before 2.3.0; 3.0.0 to before 3.1.3 Vulnerable ·Rails Admin Project
Remediation
- Fix · CNA rails_admin (railsadminteam) Fixed in 3.1.3, 2.3.0
- Fix · GHSA-8qgm-g2vv-vwvc rails_admin (RubyGems) Fixed in 3.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-39308
- 2026-10-03 Alias added: GHSA-8qgm-g2vv-vwvc
References
Patch 4
Advisory 2
More Rails Admin Project Rails Admin vulnerabilities
- TI-2016-08564 Cross-site request forgery in https://github.com/sferik rails_admin ruby gem CVSS 3.0HIGH 8.8
- TI-2020-18510 RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms. CVSS 3.1MEDIUM 6.1
- TI-2017-08891 An exploitable cross site scripting (XSS) vulnerability exists in the add filter… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-39308 · CVE Program
- CVE-2024-39308 · NVD
- FIRST EPSS
- GHSA-8qgm-g2vv-vwvc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences