SQL injection in HackerOne sequelize node module
Priority MEDIUM 46CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. Before version 1.7.0-alpha3, sequelize defaulted SQLite to use MySQL backslash escaping, even though SQLite uses Postgres escaping.
Why it matters now
EPSS 0.01884 79th percentileScored 2026-11-07
Fix Fixed sequelize (npm): 1.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | sequelize node module | up to 1.7.0-alpha2 | — | No fix listed | CNA |
| — | sequelize (npm) | before 1.7.0 | 1.7.0 | Patch available | GHSA-x2jc-pwfj-h9p3 |
- sequelize node module VendorHackerOne Affected up to 1.7.0-alpha2 Fixed in — No fix listed CNA
- sequelize (npm) Vendor— Affected before 1.7.0 Fixed in 1.7.0 Patch available GHSA-x2jc-pwfj-h9p3
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* | up to 1.6.0 | Vulnerable | Feathers-Sequalize |
| cpe:2.3:a:sequelizejs:sequelize:1.7.0:alpha1:*:*:*:node.js:*:* | 1.7.0 alpha1 | Vulnerable | Feathers-Sequalize |
| cpe:2.3:a:sequelizejs:sequelize:1.7.0:alpha2:*:*:*:node.js:*:* | 1.7.0 alpha2 | Vulnerable | Feathers-Sequalize |
- cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* Versions up to 1.6.0 Vulnerable ·Feathers-Sequalize
- cpe:2.3:a:sequelizejs:sequelize:1.7.0:alpha1:*:*:*:node.js:*:* Versions 1.7.0 alpha1 Vulnerable ·Feathers-Sequalize
- cpe:2.3:a:sequelizejs:sequelize:1.7.0:alpha2:*:*:*:node.js:*:* Versions 1.7.0 alpha2 Vulnerable ·Feathers-Sequalize
Remediation
- Fix · GHSA-x2jc-pwfj-h9p3 sequelize (npm) Fixed in 1.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10554
- 2026-10-03 Alias added: GHSA-x2jc-pwfj-h9p3
References
More Feathers-Sequalize Sequelize vulnerabilities
- TI-2023-11083 SQL Injection via replacements in sequelize CVSS 3.1CRITICAL 10.0
- TI-2023-08773 Sequalize - Default support for “raw attributes” when using parentheses CVSS 3.1CRITICAL 10.0
- TI-2016-08591 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2019-08017 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
- TI-2019-08014 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
- TI-2019-08013 SQL injection in Sequelize CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-10554 · CVE Program
- CVE-2016-10554 · NVD
- FIRST EPSS
- GHSA-x2jc-pwfj-h9p3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences