SQL injection in sequelize
Priority MEDIUM 45CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escaping values properly when formatting sub paths for JSON queries for MySQL, MariaDB and SQLite.
Why it matters now
EPSS 0.01462 73rd percentileScored 2026-11-07
Fix Fixed sequelize (npm): 4.44.3, 5.15.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | sequelize | All versions prior to version 4.44.3 and 5.15.1 | — | No fix listed | CNA |
| — | sequelize (npm) | before 4.44.3 | 4.44.3 | Patch available | GHSA-m9jw-237r-gvfv |
| — | sequelize (npm) | 5.0.0 to before 5.15.1 | 5.15.1 | Patch available | GHSA-m9jw-237r-gvfv |
- sequelize Vendor— Affected All versions prior to version 4.44.3 and 5.15.1 Fixed in — No fix listed CNA
- sequelize (npm) Vendor— Affected before 4.44.3 Fixed in 4.44.3 Patch available GHSA-m9jw-237r-gvfv
- sequelize (npm) Vendor— Affected 5.0.0 to before 5.15.1 Fixed in 5.15.1 Patch available GHSA-m9jw-237r-gvfv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* | 4.0.0 to before 4.44.3; 5.0.0 to before 5.15.1 | Vulnerable | Feathers-Sequalize |
- cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* Versions 4.0.0 to before 4.44.3; 5.0.0 to before 5.15.1 Vulnerable ·Feathers-Sequalize
Remediation
- Fix · GHSA-m9jw-237r-gvfv sequelize (npm) Fixed in 4.44.3 Advisory →
- Fix · GHSA-m9jw-237r-gvfv sequelize (npm) Fixed in 5.15.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10752
- 2026-10-03 Alias added: GHSA-m9jw-237r-gvfv
References
More Feathers-Sequalize Sequelize vulnerabilities
- TI-2023-11083 SQL Injection via replacements in sequelize CVSS 3.1CRITICAL 10.0
- TI-2023-08773 Sequalize - Default support for “raw attributes” when using parentheses CVSS 3.1CRITICAL 10.0
- TI-2016-08595 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2016-08591 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2019-08014 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
- TI-2019-08013 SQL injection in Sequelize CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-10752 · CVE Program
- CVE-2019-10752 · NVD
- FIRST EPSS
- GHSA-m9jw-237r-gvfv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences