SQL injection in Sequelize
Priority MEDIUM 45CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
Why it matters now
EPSS 0.01315 70th percentileScored 2026-11-07
Fix Fixed Sequelize: 3.35.1, 4.44.3, 5.8.11sequelize (npm): 3.35.1, 4.44.3, 5.8.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Sequelize | before 3.35.1; before 4.44.3; before 5.8.11 | 3.35.1, 4.44.3, 5.8.11 | Patch available | CNA |
| — | sequelize (npm) | before 3.35.1 | 3.35.1 | Patch available | GHSA-j9xp-92vc-559j |
| — | sequelize (npm) | 4.0.0 to before 4.44.3 | 4.44.3 | Patch available | GHSA-j9xp-92vc-559j |
| — | sequelize (npm) | 5.0.0 to before 5.8.11 | 5.8.11 | Patch available | GHSA-j9xp-92vc-559j |
- Sequelize Vendor— Affected before 3.35.1; before 4.44.3; before 5.8.11 Fixed in 3.35.1, 4.44.3, 5.8.11 Patch available CNA
- sequelize (npm) Vendor— Affected before 3.35.1 Fixed in 3.35.1 Patch available GHSA-j9xp-92vc-559j
- sequelize (npm) Vendor— Affected 4.0.0 to before 4.44.3 Fixed in 4.44.3 Patch available GHSA-j9xp-92vc-559j
- sequelize (npm) Vendor— Affected 5.0.0 to before 5.8.11 Fixed in 5.8.11 Patch available GHSA-j9xp-92vc-559j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* | 3.0.0 to before 3.35.1; 4.0.0 to before 4.44.3; 5.0.0 – 5.8.11 | Vulnerable | Feathers-Sequalize |
- cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* Versions 3.0.0 to before 3.35.1; 4.0.0 to before 4.44.3; 5.0.0 – 5.8.11 Vulnerable ·Feathers-Sequalize
Remediation
- Fix · CNA Sequelize Fixed in 3.35.1, 4.44.3, 5.8.11
- Fix · GHSA-j9xp-92vc-559j sequelize (npm) Fixed in 3.35.1 Advisory →
- Fix · GHSA-j9xp-92vc-559j sequelize (npm) Fixed in 4.44.3 Advisory →
- Fix · GHSA-j9xp-92vc-559j sequelize (npm) Fixed in 5.8.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10748
- 2026-10-03 Alias added: GHSA-j9xp-92vc-559j
References
More Feathers-Sequalize Sequelize vulnerabilities
- TI-2023-11083 SQL Injection via replacements in sequelize CVSS 3.1CRITICAL 10.0
- TI-2023-08773 Sequalize - Default support for “raw attributes” when using parentheses CVSS 3.1CRITICAL 10.0
- TI-2016-08595 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2016-08591 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2019-08017 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
- TI-2019-08014 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-10748 · CVE Program
- CVE-2019-10748 · NVD
- FIRST EPSS
- GHSA-j9xp-92vc-559j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences