SQL injection in HackerOne sequelize node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS In Postgres, SQLite, and Microsoft SQL Server there is an issue where arrays are treated as strings and improperly escaped. This causes potential SQL injection in sequelize 3.19.3 and earlier, where a malicious user could put `["test", "'); DELETE TestTable WHERE Id = 1 --')"]` inside of ``` database.query('SELECT * FROM TestTable WHERE Name IN (:names)', { replacements: { names: directCopyOfUserInput } }); ``` and cause the SQL statement to become `SELECT Id FROM Table WHERE Name IN ('test', '\'); DELETE TestTable WHERE Id = 1 --')`. In Postgres, MSSQL, and SQLite, the backslash has no special meaning. This causes the the statement to delete whichever Id has a value of 1 in the TestTable table.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | sequelize node module | up to 3.19.3 | — | No fix listed | CNA |
| — | sequelize (npm) | before 3.20.0 | 3.20.0 | Patch available | GHSA-9c2p-jw8p-f84v |
- sequelize node module VendorHackerOne Affected up to 3.19.3 Fixed in — No fix listed CNA
- sequelize (npm) Vendor— Affected before 3.20.0 Fixed in 3.20.0 Patch available GHSA-9c2p-jw8p-f84v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* | up to 3.19.3 | Vulnerable | Feathers-Sequalize |
- cpe:2.3:a:sequelizejs:sequelize:*:*:*:*:*:node.js:*:* Versions up to 3.19.3 Vulnerable ·Feathers-Sequalize
Remediation
- Fix · GHSA-9c2p-jw8p-f84v sequelize (npm) Fixed in 3.20.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-10556
- 2026-10-03 Alias added: GHSA-9c2p-jw8p-f84v
References
More Feathers-Sequalize Sequelize vulnerabilities
- TI-2023-11083 SQL Injection via replacements in sequelize CVSS 3.1CRITICAL 10.0
- TI-2023-08773 Sequalize - Default support for “raw attributes” when using parentheses CVSS 3.1CRITICAL 10.0
- TI-2016-08595 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2016-08591 SQL injection in HackerOne sequelize node module CVSS 3.0CRITICAL 9.8
- TI-2019-08017 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
- TI-2019-08014 SQL injection in sequelize CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-10556 · CVE Program
- CVE-2016-10556 · NVD
- FIRST EPSS
- GHSA-9c2p-jw8p-f84v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences