An issue was discovered in includes/component.php in the BuddyPress Docs plugin before…
Priority LOW 22CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
An issue was discovered in includes/component.php in the BuddyPress Docs plugin before 1.9.3 for WordPress. It is possible for authenticated users to edit documents of other users without proper permissions.
Why it matters now
EPSS 0.01121 66th percentileScored 2026-11-07
Fix Fixed buddypress/buddypress (Packagist): 1.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | buddypress/buddypress (Packagist) | before 1.9.3 | 1.9.3 | Patch available | GHSA-9wf6-88x4-6xvj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- buddypress/buddypress (Packagist) Vendor— Affected before 1.9.3 Fixed in 1.9.3 Patch available GHSA-9wf6-88x4-6xvj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:*:*:* | up to 1.9.2 | Vulnerable | buddypress |
- cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:*:*:* Versions up to 1.9.2 Vulnerable ·buddypress
Remediation
- Fix · GHSA-9wf6-88x4-6xvj buddypress/buddypress (Packagist) Fixed in 1.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6954
- 2026-10-03 Alias added: GHSA-9wf6-88x4-6xvj
References
More Buddypress vulnerabilities
- TI-2021-04488 BuddyPress privilege escalation via REST API CVSS 3.1HIGH 8.8
- TI-2014-01473 The Group creation process in the Buddypress plugin before 1.9.2 for WordPress allows… CVSS 3.0MEDIUM 6.5
- TI-2024-09291 BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal CVSS 3.1HIGH 8.1
- TI-2020-04300 Private data exposure via REST API in BuddyPress CVSS 3.1HIGH 8.0
- TI-2012-01882 SQL injection vulnerability in wp-load.php in the BuddyPress plugin 1.5.x before 1.5.5 of… CVSS 2.0HIGH 7.5
- TI-2025-17565 WordPress Mass Messaging in BuddyPress Plugin <= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2017-6954 · CVE Program
- CVE-2017-6954 · NVD
- FIRST EPSS
- GHSA-9wf6-88x4-6xvj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences