When handling a decoding failure for a malformed URL path of an HTTP request, libprocess…
Priority LOW 38Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
When handling a decoding failure for a malformed URL path of an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev might crash because the code accidentally calls inappropriate function. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Why it matters now
EPSS 0.02448 84th percentileScored 2026-11-07
Fix Fixed Apache Mesos (Apache Software Foundation): 1.1.3, 1.2.2, 1.3.1org.apache.mesos:mesos (Maven): 1.1.3, 1.2.2, 1.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Mesos | before 1.1.3; 1.2 to before 1.2.2; 1.3 to before 1.3.1; 1.4.0-dev | 1.1.3, 1.2.2, 1.3.1 | Patch available | CNA |
| — | org.apache.mesos:mesos (Maven) | before 1.1.3 | 1.1.3 | Patch available | GHSA-x869-784m-jmj2 |
| — | org.apache.mesos:mesos (Maven) | 1.2.0 to before 1.2.2 | 1.2.2 | Patch available | GHSA-x869-784m-jmj2 |
| — | org.apache.mesos:mesos (Maven) | 1.3.0 to before 1.3.1 | 1.3.1 | Patch available | GHSA-x869-784m-jmj2 |
- Apache Mesos VendorApache Affected before 1.1.3; 1.2 to before 1.2.2; 1.3 to before 1.3.1; 1.4.0-dev Fixed in 1.1.3, 1.2.2, 1.3.1 Patch available CNA
- org.apache.mesos:mesos (Maven) Vendor— Affected before 1.1.3 Fixed in 1.1.3 Patch available GHSA-x869-784m-jmj2
- org.apache.mesos:mesos (Maven) Vendor— Affected 1.2.0 to before 1.2.2 Fixed in 1.2.2 Patch available GHSA-x869-784m-jmj2
- org.apache.mesos:mesos (Maven) Vendor— Affected 1.3.0 to before 1.3.1 Fixed in 1.3.1 Patch available GHSA-x869-784m-jmj2
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:* | up to 1.1.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.2.0:*:*:*:*:*:*:* | 1.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.3.1:*:*:*:*:*:*:* | 1.3.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.4.0-dev:*:*:*:*:*:*:* | 1.4.0-dev | Vulnerable | Apache |
- cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:* Versions up to 1.1.2 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.2.0:*:*:*:*:*:*:* Versions 1.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.3.1:*:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.4.0-dev:*:*:*:*:*:*:* Versions 1.4.0-dev Vulnerable ·Apache
Remediation
- Fix · CNA Apache Mesos (Apache Software Foundation) Fixed in 1.1.3, 1.2.2, 1.3.1
- Fix · GHSA-x869-784m-jmj2 org.apache.mesos:mesos (Maven) Fixed in 1.1.3 Advisory →
- Fix · GHSA-x869-784m-jmj2 org.apache.mesos:mesos (Maven) Fixed in 1.2.2 Advisory →
- Fix · GHSA-x869-784m-jmj2 org.apache.mesos:mesos (Maven) Fixed in 1.3.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7687
- 2026-10-03 Alias added: GHSA-x869-784m-jmj2
References
More Apache Mesos vulnerabilities
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2018-08449 Memory corruption in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2019-00180 A specifically crafted Docker image running under the root user can overwrite the init… CVSS 3.1HIGH 7.8
- TI-2018-01231 Improper input validation in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2017-07170 Use after free in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2018-15893 An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier… CVSS 3.0MEDIUM 6.5
Sources
- CVE-2017-7687 · CVE Program
- CVE-2017-7687 · NVD
- FIRST EPSS
- GHSA-x869-784m-jmj2 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7687 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences