An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier…
Priority LOW 32CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier in MesosCloud.java that allows attackers with Overall/Read access to obtain credentials IDs for credentials stored in Jenkins.
Why it matters now
EPSS 0.01449 73rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:mesos (Maven): 0.18
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:mesos (Maven) | before 0.18 | 0.18 | Patch available | GHSA-23xr-9xxr-vg3c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:mesos (Maven) Vendor— Affected before 0.18 Fixed in 0.18 Patch available GHSA-23xr-9xxr-vg3c
Remediation
- Fix · GHSA-23xr-9xxr-vg3c org.jenkins-ci.plugins:mesos (Maven) Fixed in 0.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000420
- 2026-10-03 Alias added: GHSA-23xr-9xxr-vg3c
References
More Apache Mesos vulnerabilities
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2018-08449 Memory corruption in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2019-00180 A specifically crafted Docker image running under the root user can overwrite the init… CVSS 3.1HIGH 7.8
- TI-2018-01231 Improper input validation in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2017-07170 Use after free in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2017-05323 When handling a decoding failure for a malformed URL path of an HTTP request, libprocess… CVSS 3.0HIGH 7.5
Sources
- CVE-2018-1000420 · CVE Program
- CVE-2018-1000420 · NVD
- FIRST EPSS
- GHSA-23xr-9xxr-vg3c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences