Improper input validation in Apache Mesos
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-248.
Summary
When parsing a malformed JSON payload, libprocess in Apache Mesos versions 1.4.0 to 1.5.0 might crash due to an uncaught exception. Parsing chunked HTTP requests with trailers can lead to a libprocess crash too because of the mistakenly planted assertion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Mesos | 1.4.0 to 1.5.0 | — | No fix listed | CNA |
| — | org.apache.mesos:mesos (Maven) | 1.4.0 to before 1.6.0 | 1.6.0 | Patch available | GHSA-95q3-pppp-r683 |
- Apache Mesos VendorApache Affected 1.4.0 to 1.5.0 Fixed in — No fix listed CNA
- org.apache.mesos:mesos (Maven) Vendor— Affected 1.4.0 to before 1.6.0 Fixed in 1.6.0 Patch available GHSA-95q3-pppp-r683
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:* | 1.4.0 to before 1.4.2; 1.5.0 to before 1.5.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.4.0:rc1:*:*:*:*:*:* | 1.4.0 rc1 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.4.0:rc2:*:*:*:*:*:* | 1.4.0 rc2 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.4.0:rc3:*:*:*:*:*:* | 1.4.0 rc3 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.4.0:rc4:*:*:*:*:*:* | 1.4.0 rc4 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.4.0:rc5:*:*:*:*:*:* | 1.4.0 rc5 | Vulnerable | Apache |
| cpe:2.3:a:apache:mesos:1.6.0:rc1:*:*:*:*:*:* | 1.6.0 rc1 | Vulnerable | Apache |
- cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.4.2; 1.5.0 to before 1.5.1 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.4.0:rc1:*:*:*:*:*:* Versions 1.4.0 rc1 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.4.0:rc2:*:*:*:*:*:* Versions 1.4.0 rc2 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.4.0:rc3:*:*:*:*:*:* Versions 1.4.0 rc3 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.4.0:rc4:*:*:*:*:*:* Versions 1.4.0 rc4 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.4.0:rc5:*:*:*:*:*:* Versions 1.4.0 rc5 Vulnerable ·Apache
- cpe:2.3:a:apache:mesos:1.6.0:rc1:*:*:*:*:*:* Versions 1.6.0 rc1 Vulnerable ·Apache
Remediation
- Fix · GHSA-95q3-pppp-r683 org.apache.mesos:mesos (Maven) Fixed in 1.6.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1330
- 2026-10-03 Alias added: GHSA-95q3-pppp-r683
References
More Apache Mesos vulnerabilities
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2018-08449 Memory corruption in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2019-00180 A specifically crafted Docker image running under the root user can overwrite the init… CVSS 3.1HIGH 7.8
- TI-2017-07170 Use after free in Apache Mesos CVSS 3.0HIGH 7.5
- TI-2017-05323 When handling a decoding failure for a malformed URL path of an HTTP request, libprocess… CVSS 3.0HIGH 7.5
- TI-2018-15893 An improper authorization vulnerability exists in Jenkins Mesos Plugin 0.17.1 and earlier… CVSS 3.0MEDIUM 6.5
Sources
- CVE-2018-1330 · CVE Program
- CVE-2018-1330 · NVD
- FIRST EPSS
- GHSA-95q3-pppp-r683 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1330 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences