Improper privilege management in Puppet Enterprise
Priority LOW 25CWE-269Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 2 fixed, 9 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-269.
Summary
In previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.
Why it matters now
EPSS 0.00356 29th percentileScored 2026-11-07
Fix Partial puppet (RubyGems): 4.10.10, 5.3.4Red Hat: 1 advisoryRed Hat: 2 fixed, 9 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Puppet | Puppet Enterprise | prior to 2016.4.10 or 2017.3.4 | — | No fix listed | CNA |
| Puppet | Puppet Agent | prior to 5.3.4 or 1.10.10 | — | No fix listed | CNA |
| — | puppet (RubyGems) | before 4.10.10 | 4.10.10 | Patch available | GHSA-vw22-465p-8j5w |
| — | puppet (RubyGems) | 5.0.0 to before 5.3.4 | 5.3.4 | Patch available | GHSA-vw22-465p-8j5w |
- Puppet Enterprise VendorPuppet Affected prior to 2016.4.10 or 2017.3.4 Fixed in — No fix listed CNA
- Puppet Agent VendorPuppet Affected prior to 5.3.4 or 1.10.10 Fixed in — No fix listed CNA
- puppet (RubyGems) Vendor— Affected before 4.10.10 Fixed in 4.10.10 Patch available GHSA-vw22-465p-8j5w
- puppet (RubyGems) Vendor— Affected 5.0.0 to before 5.3.4 Fixed in 5.3.4 Patch available GHSA-vw22-465p-8j5w
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:puppet:*:*:*:*:*:*:*:* | before 5.3.4; 1.10.0 to before 1.10.10 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | before 2016.4.10; 2017.1.0 to before 2017.3.4 | Vulnerable | Puppet |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:a:redhat:satellite:6.4:*:*:*:*:*:*:* | 6.4 | Vulnerable | Red Hat |
- cpe:2.3:a:puppet:puppet:*:*:*:*:*:*:*:* Versions before 5.3.4; 1.10.0 to before 1.10.10 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions before 2016.4.10; 2017.1.0 to before 2017.3.4 Vulnerable ·Puppet
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:a:redhat:satellite:6.4:*:*:*:*:*:*:* Versions 6.4 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-vw22-465p-8j5w puppet (RubyGems) Fixed in 4.10.10 Advisory →
- Fix · GHSA-vw22-465p-8j5w puppet (RubyGems) Fixed in 5.3.4 Advisory →
Red Hat 1 advisory
- RHSA-2018:2927 Released 2018-10-16 · Red Hat rating ImportantSatellite 6.4 security, bug fix, and enhancement update
- Red Hat Satellite 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, candlepin-2.4.8-1.el7 +47
- Red Hat Satellite Capsule 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, createrepo_c-0.7.4-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 6 (Juno) | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 11 (Ocata) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 8 (Liberty) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.4 | Fixed | RHSA-2018:2927 |
| Red Hat Satellite Capsule 6.4 | Fixed | RHSA-2018:2927 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-10689
- 2026-10-03 Alias added: GHSA-vw22-465p-8j5w
References
Advisory 4
Other 6
- https://github.com/puppetlabs/puppet/commit/17d9e02da3882e44c1876e2805cf9708481715ee
- https://github.com/puppetlabs/puppet/commit/2f1047f85e22cde139a421bc25d371f2ffc92cb1
- https://github.com/puppetlabs/puppet
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2017-10689.yml
- https://tickets.puppetlabs.com/browse/PUP-7866
- https://usn.ubuntu.com/3567-1
More Puppet vulnerabilities
- TI-2016-02327 Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet… CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2021-08594 SQL injection in Puppet DB CVSS 3.1HIGH 8.8
- TI-2017-01576 Deserialization of untrusted data in Puppet server CVSS 3.0HIGH 8.2
- TI-2018-04793 Untrusted search path in Puppet Enterprise and Puppet Agent CVSS 3.0HIGH 8.8
- TI-2013-01456 Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later… CVSS 2.0HIGH 7.5
Sources
- CVE-2017-10689 · CVE Program
- CVE-2017-10689 · NVD
- FIRST EPSS
- GHSA-vw22-465p-8j5w · GitHub Advisory Database · CC BY 4.0
- CVE-2017-10689 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences