Improper privilege management in Puppet Enterprise
Priority LOW 31CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-269.
Summary
In previous versions of Puppet Agent it was possible for the agent to retrieve facts from an environment that it was not classified to retrieve from. This was resolved in Puppet Agent 5.3.4, included in Puppet Enterprise 2017.3.4
Why it matters now
EPSS 0.01 63rd percentileScored 2026-11-07
Fix Fixed Puppet Enterprise (Puppet): 2017.3.4Puppet Agent (Puppet): 5.3.4Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Puppet | Puppet Enterprise | 2017.3 to before 2017.3.4 | 2017.3.4 | Patch available | CNA |
| Puppet | Puppet Agent | 5 to before 5.3.4 | 5.3.4 | Patch available | CNA |
Remediation
- Fix · CNA Puppet Enterprise (Puppet) Fixed in 2017.3.4
- Fix · CNA Puppet Agent (Puppet) Fixed in 5.3.4
Red Hat 1 advisory
- RHSA-2018:2927 Released 2018-10-16 · Red Hat rating ImportantSatellite 6.4 security, bug fix, and enhancement update
- Red Hat Satellite 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, candlepin-2.4.8-1.el7 +47
- Red Hat Satellite Capsule 6.4 SOAPpy-0.11.6-17.el7, ansiblerole-insights-client-1.5-1.el7sat, createrepo_c-0.7.4-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6.4 | Fixed | RHSA-2018:2927 |
| Red Hat Satellite Capsule 6.4 | Fixed | RHSA-2018:2927 |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-10690
- 2026-10-03 Alias added: GHSA-v5m5-pcq8-cjj7
References
More Puppet vulnerabilities
- TI-2016-02327 Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet… CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2021-08594 SQL injection in Puppet DB CVSS 3.1HIGH 8.8
- TI-2017-01576 Deserialization of untrusted data in Puppet server CVSS 3.0HIGH 8.2
- TI-2018-04793 Untrusted search path in Puppet Enterprise and Puppet Agent CVSS 3.0HIGH 8.8
- TI-2013-01456 Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later… CVSS 2.0HIGH 7.5
Sources
- CVE-2017-10690 · CVE Program
- CVE-2017-10690 · NVD
- FIRST EPSS
- GHSA-v5m5-pcq8-cjj7 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-10690 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences