NewStatPress Plugin Persistent cross site scriting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-80.
Summary
A vulnerability, which was classified as problematic, has been found in NewStatPress Plugin 1.2.4. This issue affects some unknown processing. The manipulation leads to basic cross site scripting (Persistent). The attack may be initiated remotely. Upgrading to version 1.2.5 is able to address this issue. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | NewStatPress Plugin | 1.2.4 | — | No fix listed | CNA |
- NewStatPress Plugin Vendorunspecified Affected 1.2.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:newstatpress_project:newstatpress:1.2.4:*:*:*:*:wordpress:*:* | 1.2.4 | Vulnerable | Newstatpress Project |
- cpe:2.3:a:newstatpress_project:newstatpress:1.2.4:*:*:*:*:wordpress:*:* Versions 1.2.4 Vulnerable ·Newstatpress Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-20094
- 2026-10-03 Alias added: GHSA-65pg-wc47-9p36
References
More Newstatpress Project Newstatpress vulnerabilities
- TI-2015-07692 The newstatpress plugin before 1.0.1 for WordPress has SQL injection. CVSS 3.0CRITICAL 9.8
- TI-2015-07690 The newstatpress plugin before 1.0.5 for WordPress has SQL injection related to an IMG element. CVSS 3.0CRITICAL 9.8
- TI-2015-03423 SQL injection vulnerability in includes/nsp_search.php in the NewStatPress plugin before… CVSS 2.0MEDIUM 6.5
- TI-2015-07689 The newstatpress plugin before 1.0.5 for WordPress has XSS related to an IMG element. CVSS 3.0MEDIUM 6.1
- TI-2022-00143 NewStatPress < 1.3.6 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2017-13748 The newstatpress plugin before 1.2.5 for WordPress has multiple stored XSS issues. CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-20094 · CVE Program
- CVE-2017-20094 · NVD
- FIRST EPSS
- GHSA-65pg-wc47-9p36 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences