Read the docs
TI-2022-00143 Aliases CVE-2022-0206GHSA-rp96-45rp-9v6p

NewStatPress < 1.3.6 - Reflected Cross-Site Scripting

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The NewStatPress WordPress plugin before 1.3.6 does not properly escape the whatX parameters before outputting them back in attributes, leading to Reflected Cross-Site Scripting issues

Why it matters now

EPSS 0.01446 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed NewStatPress (Unknown): 1.3.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNewStatPress1.3.6 to before 1.3.61.3.6Patch availableCNA
  • NewStatPress VendorUnknown Affected 1.3.6 to before 1.3.6 Fixed in 1.3.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:newstatpress_project:newstatpress:*:*:*:*:*:wordpress:*:*before 1.3.6VulnerableNewstatpress Project
  • cpe:2.3:a:newstatpress_project:newstatpress:*:*:*:*:*:wordpress:*:* Versions before 1.3.6 Vulnerable ·Newstatpress Project

Remediation

  • Fix · CNA NewStatPress (Unknown) Fixed in 1.3.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0206
  2. 2026-10-03 Alias added: GHSA-rp96-45rp-9v6p

References

  • TI-2017-14160 NewStatPress Plugin Persistent cross site scriting CVSS 3.1MEDIUM 5.4
  • TI-2015-07692 The newstatpress plugin before 1.0.1 for WordPress has SQL injection. CVSS 3.0CRITICAL 9.8
  • TI-2015-07690 The newstatpress plugin before 1.0.5 for WordPress has SQL injection related to an IMG element. CVSS 3.0CRITICAL 9.8
  • TI-2015-03423 SQL injection vulnerability in includes/nsp_search.php in the NewStatPress plugin before… CVSS 2.0MEDIUM 6.5
  • TI-2015-07689 The newstatpress plugin before 1.0.5 for WordPress has XSS related to an IMG element. CVSS 3.0MEDIUM 6.1
  • TI-2017-13748 The newstatpress plugin before 1.2.5 for WordPress has multiple stored XSS issues. CVSS 3.0MEDIUM 6.1
See all 9 →

Sources