Script Security Plugin did not apply sandboxing restrictions to constructor invocations…
Priority MEDIUM 40Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Script Security Plugin did not apply sandboxing restrictions to constructor invocations via positional arguments list, super constructor invocations, method references, and type coercion expressions. This could be used to invoke arbitrary constructors and methods, bypassing sandbox protection.
Why it matters now
EPSS 0.01204 68th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:script-security (Maven): 1.31Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.31 | 1.31 | Patch available | GHSA-h7rx-r733-7x7r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.31 Fixed in 1.31 Patch available GHSA-h7rx-r733-7x7r
Remediation
- Fix · GHSA-h7rx-r733-7x7r org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.31 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000107
- 2026-10-03 Alias added: GHSA-h7rx-r733-7x7r
References
More Jenkins Script Security vulnerabilities
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
- TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2017-1000107 · CVE Program
- CVE-2017-1000107 · NVD
- FIRST EPSS
- GHSA-h7rx-r733-7x7r · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000107 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences