The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and…
Priority LOW 30Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).
Why it matters now
EPSS 0.00624 50th percentileScored 2026-11-07
Fix Fixed fscrypt (The fscrypt Project): 0.2.4github.com/google/fscrypt (Go): 0.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| The fscrypt Project | fscrypt | before 0.2.4 | 0.2.4 | Patch available | CNA |
| — | github.com/google/fscrypt (Go) | before 0.2.4 | 0.2.4 | Patch available | GHSA-qj26-7grj-whg3 |
- fscrypt VendorThe fscrypt Project Affected before 0.2.4 Fixed in 0.2.4 Patch available CNA
- github.com/google/fscrypt (Go) Vendor— Affected before 0.2.4 Fixed in 0.2.4 Patch available GHSA-qj26-7grj-whg3
Remediation
- Fix · CNA fscrypt (The fscrypt Project) Fixed in 0.2.4
- Fix · GHSA-qj26-7grj-whg3 github.com/google/fscrypt (Go) Fixed in 0.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6558
- 2026-10-03 Alias added: GHSA-qj26-7grj-whg3
- 2026-11-04 EPSS moved to the 50th–90th percentile
References
Patch 3
More Google Fscrypt vulnerabilities
- TI-2022-09020 Privilege escalation through command injection in fscrypt CVSS 3.1HIGH 7.3
- TI-2022-09019 Local Denial of Service in fscrypt PAM module CVSS 3.1MEDIUM 5.5
- TI-2022-09018 Denial of Service in fscrypt CVSS 3.1MEDIUM 5.5
Sources
- CVE-2018-6558 · CVE Program
- CVE-2018-6558 · NVD
- FIRST EPSS
- GHSA-qj26-7grj-whg3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences