Read the docs
TI-2022-09019 Aliases CVE-2022-25327GHSA-8vwm-8vj8-rqjf

Local Denial of Service in fscrypt PAM module

Priority LOW 24CWE-255Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00114 1st percentileScored 2026-11-07
Fix Fixed github.com/google/fscrypt (Go): 0.3.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googlefscryptup to 0.3.2—No fix listedCNA
—github.com/google/fscrypt (Go)before 0.3.30.3.3Patch availableGHSA-8vwm-8vj8-rqjf
  • fscrypt VendorGoogle Affected up to 0.3.2 Fixed in — No fix listed CNA
  • github.com/google/fscrypt (Go) Vendor— Affected before 0.3.3 Fixed in 0.3.3 Patch available GHSA-8vwm-8vj8-rqjf

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:google:fscrypt:*:*:*:*:*:*:*:*before 0.3.3VulnerableGoogle
  • cpe:2.3:a:google:fscrypt:*:*:*:*:*:*:*:* Versions before 0.3.3 Vulnerable ·Google

Remediation

  • Fix · GHSA-8vwm-8vj8-rqjf github.com/google/fscrypt (Go) Fixed in 0.3.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-25327
  2. 2026-10-03 Alias added: GHSA-8vwm-8vj8-rqjf

References

  • TI-2022-09020 Privilege escalation through command injection in fscrypt CVSS 3.1HIGH 7.3
  • TI-2018-04834 The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and… CVSS 3.0MEDIUM 6.5
  • TI-2022-09018 Denial of Service in fscrypt CVSS 3.1MEDIUM 5.5

Sources