Privilege escalation through command injection in fscrypt
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The bash_completion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fscrypt | up to 0.3.2 | — | No fix listed | CNA | |
| — | github.com/google/fscrypt (Go) | before 0.3.3 | 0.3.3 | Patch available | GHSA-wxjg-p59j-6c92 |
- fscrypt VendorGoogle Affected up to 0.3.2 Fixed in — No fix listed CNA
- github.com/google/fscrypt (Go) Vendor— Affected before 0.3.3 Fixed in 0.3.3 Patch available GHSA-wxjg-p59j-6c92
Remediation
- Fix · GHSA-wxjg-p59j-6c92 github.com/google/fscrypt (Go) Fixed in 0.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25328
- 2026-10-03 Alias added: GHSA-wxjg-p59j-6c92
References
More Google Fscrypt vulnerabilities
- TI-2018-04834 The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and… CVSS 3.0MEDIUM 6.5
- TI-2022-09019 Local Denial of Service in fscrypt PAM module CVSS 3.1MEDIUM 5.5
- TI-2022-09018 Denial of Service in fscrypt CVSS 3.1MEDIUM 5.5
Sources
- CVE-2022-25328 · CVE Program
- CVE-2022-25328 · NVD
- FIRST EPSS
- GHSA-wxjg-p59j-6c92 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences