Denial of Service in fscrypt
Priority LOW 24CWE-400Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00131 2nd percentileScored 2026-11-07
Fix Fixed github.com/google/fscrypt (Go): 0.3.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fscrypt | up to 0.3.2 | — | No fix listed | CNA | |
| — | github.com/google/fscrypt (Go) | before 0.3.3 | 0.3.3 | Patch available | GHSA-mpq4-rjj8-fjph |
- fscrypt VendorGoogle Affected up to 0.3.2 Fixed in — No fix listed CNA
- github.com/google/fscrypt (Go) Vendor— Affected before 0.3.3 Fixed in 0.3.3 Patch available GHSA-mpq4-rjj8-fjph
Remediation
- Fix · GHSA-mpq4-rjj8-fjph github.com/google/fscrypt (Go) Fixed in 0.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25326
- 2026-10-03 Alias added: GHSA-mpq4-rjj8-fjph
References
More Google Fscrypt vulnerabilities
- TI-2022-09020 Privilege escalation through command injection in fscrypt CVSS 3.1HIGH 7.3
- TI-2018-04834 The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and… CVSS 3.0MEDIUM 6.5
- TI-2022-09019 Local Denial of Service in fscrypt PAM module CVSS 3.1MEDIUM 5.5
Sources
- CVE-2022-25326 · CVE Program
- CVE-2022-25326 · NVD
- FIRST EPSS
- GHSA-mpq4-rjj8-fjph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences