Read the docs
TI-2018-12069 Aliases CVE-2018-16859GHSA-v735-2pp6-h86r

Sensitive information in log files in Red Hat ansible

Priority LOW 21CWE-532Published · Updated

Key facts

Attack vector
Local
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Partial Red Hat: 4 fixed, 11 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-532.

Summary

Execution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' passwords to appear in EventLogs in plaintext. A local user with administrator privileges on the machine can view these logs and discover the plaintext password. Ansible Engine 2.8 and older are believed to be vulnerable.

Why it matters now

EPSS 0.00535 45th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.7.3, 2.5.12, 2.6.9Red Hat: 4 advisoriesRed Hat: 4 fixed, 11 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red Hatansible2.8 and older—No fix listedCNA
—ansible (PyPI)2.7.0a1 to before 2.7.32.7.3Patch availableGHSA-v735-2pp6-h86r
—ansible (PyPI)before 2.5.122.5.12Patch availableGHSA-v735-2pp6-h86r
—ansible (PyPI)2.6.0a1 to before 2.6.92.6.9Patch availableGHSA-v735-2pp6-h86r
  • ansible VendorRed Hat Affected 2.8 and older Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected 2.7.0a1 to before 2.7.3 Fixed in 2.7.3 Patch available GHSA-v735-2pp6-h86r
  • ansible (PyPI) Vendor— Affected before 2.5.12 Fixed in 2.5.12 Patch available GHSA-v735-2pp6-h86r
  • ansible (PyPI) Vendor— Affected 2.6.0a1 to before 2.6.9 Fixed in 2.6.9 Patch available GHSA-v735-2pp6-h86r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:*before 2.5.13; 2.6.0 to before 2.6.10; 2.7.0 to before 2.7.4; 2.7.5 – 2.8VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* Versions before 2.5.13; 2.6.0 to before 2.6.10; 2.7.0 to before 2.7.4; 2.7.5 – 2.8 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-v735-2pp6-h86r ansible (PyPI) Fixed in 2.7.3 Advisory →
  • Fix · GHSA-v735-2pp6-h86r ansible (PyPI) Fixed in 2.5.12 Advisory →
  • Fix · GHSA-v735-2pp6-h86r ansible (PyPI) Fixed in 2.6.9 Advisory →

Red Hat 4 advisories

  • RHSA-2018:3771 Released 2018-12-04 · Red Hat rating Moderate
    ansible security and bug fix update
    • Red Hat Ansible Engine 2.6 for RHEL 7 Server ansible-2.6.10-1.el7ae
  • RHSA-2018:3772 Released 2018-12-04 · Red Hat rating Moderate
    ansible security and bug fix update
    • Red Hat Ansible Engine 2 for RHEL 7 ansible-2.7.4-1.el7ae
  • RHSA-2018:3773 Released 2018-12-04 · Red Hat rating Moderate
    ansible security and bug fix update
    • Red Hat Ansible Engine 2.7 for RHEL 7 Server ansible-2.7.4-1.el7ae
Show 1 more Red Hat advisories
  • RHSA-2018:3770 Released 2018-12-04 · Red Hat rating Moderate
    ansible security and bug fix update
    • Red Hat Ansible Engine 2.5 for RHEL 7 Server ansible-2.5.13-1.el7ae, ansible-doc-2.5.13-1.el7ae

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ceph Storage 2AffectedNo fix planned: Will not fix
Red Hat Ceph Storage 3AffectedNo fix yet
Red Hat OpenShift Container Platform 3.4AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.5AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.6AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.7AffectedNo fix yet
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 12 (Pike)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 14 (Rocky)AffectedNo fix planned: Will not fix
Red Hat Storage 3AffectedNo fix planned: Will not fix
Red Hat Ansible Engine 2 for RHEL 7Fixed RHSA-2018:3772
Red Hat Ansible Engine 2.5 for RHEL 7 ServerFixed RHSA-2018:3770
Red Hat Ansible Engine 2.6 for RHEL 7 ServerFixed RHSA-2018:3771
Red Hat Ansible Engine 2.7 for RHEL 7 ServerFixed RHSA-2018:3773
Not affected: 7 products
  • CloudForms Management Engine 5
  • Red Hat OpenShift Container Platform 3.2
  • Red Hat OpenShift Container Platform 3.3
  • Red Hat OpenShift Enterprise 3.0
  • Red Hat OpenShift Enterprise 3.1
  • Red Hat Satellite 6
  • Red Hat Virtualization 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-16859
  2. 2026-10-03 Alias added: GHSA-v735-2pp6-h86r

References

  • TI-2018-05593 transport.py in the SSH server implementation of Paramiko before 1.17.6, 1.18.x before… CVSS 3.1CRITICAL 9.8
  • TI-2017-05127 Improper input validation in [UNKNOWN] ansible CVSS 3.1CRITICAL 9.8
  • TI-2021-03523 Information disclosure in ansible CVSS 3.1HIGH 7.5
  • TI-2019-11051 Sensitive information in log files in Red Hat Ansible CVSS 3.1HIGH 7.8
  • TI-2018-07689 Untrusted search path in [UNKNOWN] ansible CVSS 3.1HIGH 7.8
  • TI-2018-07688 Untrusted search path in [UNKNOWN] ansible CVSS 3.0HIGH 7.8
See all 24 →

Sources