cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
Priority MEDIUM 43CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
Why it matters now
EPSS 0.02007 80th percentileScored 2026-11-07
Fix Fixed mercurial (PyPI): 4.7.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mercurial (PyPI) | before 4.7.2 | 4.7.2 | Patch available | GHSA-p575-cf9h-wv42 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mercurial (PyPI) Vendor— Affected before 4.7.2 Fixed in 4.7.2 Patch available GHSA-p575-cf9h-wv42
Remediation
- Fix · GHSA-p575-cf9h-wv42 mercurial (PyPI) Fixed in 4.7.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-17983
- 2026-10-03 Alias added: GHSA-p575-cf9h-wv42
References
More Mercurial vulnerabilities
- TI-2014-07619 Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x… CVSS 3.1CRITICAL 9.8
- TI-2017-06870 In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch… CVSS 3.1HIGH 8.8
- TI-2017-14453 Mercurial prior to 4.3 did not adequately sanitize hostnames passed to ssh, leading to possible shell-injection attacks. CVSS 3.0CRITICAL 9.8
- TI-2017-12752 In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause… CVSS 3.0CRITICAL 9.8
- TI-2018-09592 mpatch.c in Mercurial before 4.6.1 mishandles integer addition and subtraction, aka OVE-20180430-0002. CVSS 3.0CRITICAL 9.8
- TI-2016-03079 The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute… CVSS 3.1HIGH 8.8
Sources
- CVE-2018-17983 · CVE Program
- CVE-2018-17983 · NVD
- FIRST EPSS
- GHSA-p575-cf9h-wv42 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-17983 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences