Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
Priority LOW 31CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
Why it matters now
EPSS 0.00906 60th percentileScored 2026-11-07
Fix Fixed contao/contao (Packagist): 3.5.37, 4.6.11, 4.4.31
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | contao/contao (Packagist) | 3.0.0 to before 3.5.37 | 3.5.37 | Patch available | GHSA-q99w-j4mj-7hj8 |
| — | contao/contao (Packagist) | 4.6.0 to before 4.6.11 | 4.6.11 | Patch available | GHSA-q99w-j4mj-7hj8 |
| — | contao/contao (Packagist) | 4.4.0 to before 4.4.31 | 4.4.31 | Patch available | GHSA-q99w-j4mj-7hj8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- contao/contao (Packagist) Vendor— Affected 3.0.0 to before 3.5.37 Fixed in 3.5.37 Patch available GHSA-q99w-j4mj-7hj8
- contao/contao (Packagist) Vendor— Affected 4.6.0 to before 4.6.11 Fixed in 4.6.11 Patch available GHSA-q99w-j4mj-7hj8
- contao/contao (Packagist) Vendor— Affected 4.4.0 to before 4.4.31 Fixed in 4.4.31 Patch available GHSA-q99w-j4mj-7hj8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:* | 3.0.0 to before 3.5.37; 4.4.0 to before 4.4.31; 4.6.0 to before 4.6.11 | Vulnerable | contao |
- cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.5.37; 4.4.0 to before 4.4.31; 4.6.0 to before 4.6.11 Vulnerable ·contao
Remediation
- Fix · GHSA-q99w-j4mj-7hj8 contao/contao (Packagist) Fixed in 3.5.37 Advisory →
- Fix · GHSA-q99w-j4mj-7hj8 contao/contao (Packagist) Fixed in 4.6.11 Advisory →
- Fix · GHSA-q99w-j4mj-7hj8 contao/contao (Packagist) Fixed in 4.4.31 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-20028
- 2026-10-03 Alias added: GHSA-q99w-j4mj-7hj8
References
More Contao Cms vulnerabilities
- TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
- TI-2019-07939 Contao 4.7 allows Use of a Key Past its Expiration Date. CVSS 3.0CRITICAL 9.8
- TI-2019-07937 Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password. CVSS 3.0CRITICAL 9.8
- TI-2017-12170 Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the… CVSS 3.0CRITICAL 9.8
- TI-2017-08073 Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute… CVSS 3.0HIGH 8.8
- TI-2019-07938 Contao 4.7 allows CSRF. CVSS 3.0HIGH 8.8
Sources
- CVE-2018-20028 · CVE Program
- CVE-2018-20028 · NVD
- FIRST EPSS
- GHSA-q99w-j4mj-7hj8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences