Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software WebVPN Denial of Service Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-399 and the CVSS impact.
Summary
A vulnerability in the WebVPN service of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to improper management of authenticated sessions in the WebVPN portal. An attacker could exploit this vulnerability by authenticating with valid credentials and accessing a specific URL in the WebVPN portal. A successful exploit could allow the attacker to cause the device to reload, resulting in a temporary DoS condition.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Adaptive Security Appliance (ASA) Software | before 9.4.4.34; before 9.6.4.25; before 9.8.4; before 9.9.2.50; before 9.10.1.17 | 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17 | Patch available | CNA |
| Cisco | Cisco Firepower Threat Defense (FTD) Software | before 6.2.3.12; before 6.3.0.3 | 6.2.3.12, 6.3.0.3 | Patch available | CNA |
- Cisco Adaptive Security Appliance (ASA) Software VendorCisco Affected before 9.4.4.34; before 9.6.4.25; before 9.8.4; before 9.9.2.50; before 9.10.1.17 Fixed in 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17 Patch available CNA
- Cisco Firepower Threat Defense (FTD) Software VendorCisco Affected before 6.2.3.12; before 6.3.0.3 Fixed in 6.2.3.12, 6.3.0.3 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | before 9.4.4.34 | Vulnerable | Cisco |
| cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5505:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5512-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5515-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5520:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5540:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions before 9.4.4.34 Vulnerable ·Cisco
- cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5505:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5512-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5515-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5520:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5540:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5585-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* | 6.2.1 to before 6.2.3.12; 6.3.0 to before 6.3.0.3 | Vulnerable | Cisco |
- cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5585-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:a:cisco:secure_firewall_threat_defense:*:*:*:*:*:*:*:* Versions 6.2.1 to before 6.2.3.12; 6.3.0 to before 6.3.0.3 Vulnerable ·Cisco
Remediation
- Fix · CNA Cisco Adaptive Security Appliance (ASA) Software (Cisco) Fixed in 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17
- Fix · CNA Cisco Firepower Threat Defense (FTD) Software (Cisco) Fixed in 6.2.3.12, 6.3.0.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Firepower Threat Defense (FTD) Software 6.2.3.12, 6.3.0.3
8 records Highest priority Priority MEDIUM 4 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2019-01320 Improper input validation in Cisco Adaptive Security Appliance SoftwarePriority MEDIUM 48
- TI-2019-01340 Credentials management flaw in Cisco Adaptive Security Appliance SoftwarePriority MEDIUM 47
- TI-2019-01334 Memory leak in Cisco Adaptive Security Appliance SoftwarePriority MEDIUM 47
- Release ·
Cisco Adaptive Security Appliance (ASA) Software 9.10.1.17, 9.4.4.34 and 3 more versions
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2019-01320 Improper input validation in Cisco Adaptive Security Appliance SoftwarePriority MEDIUM 48
- TI-2019-01339 Cisco Adaptive Security Appliance Software Cross-Site Request Forgery VulnerabilityPriority MEDIUM 40
- TI-2019-01331 Cisco Adaptive Security Appliance Software VPN Denial of Service VulnerabilityPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1693
- 2026-10-03 Alias added: GHSA-3cqj-jcvx-xhxr
References
More Cisco Adaptive Security Appliance Software vulnerabilities
- TI-2025-14628 Buffer overflow in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.9
- TI-2016-05454 Buffer overflow in Cisco Adaptive Security Appliance (ASA) Software through 9.4.2.3 on… KEVCVSS 3.1HIGH 8.8
- TI-2023-06973 Authentication bypass in Cisco Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.1
- TI-2026-82192 Denial of service in Cisco Secure Firewall ASA and FTD SSL VPN KEVCVSS 3.1HIGH 8.6
- TI-2026-16533 Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense… KEVCVSS 3.1HIGH 8.6
- TI-2025-14657 Missing authorization in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1HIGH 8.6
Sources
- CVE-2019-1693 · CVE Program
- CVE-2019-1693 · NVD
- FIRST EPSS
- GHSA-3cqj-jcvx-xhxr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences