Cisco Adaptive Security Appliance Software Cross-Site Request Forgery Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
A vulnerability in the web-based management interface of Cisco Adaptive Security Appliance (ASA) Software could allow an unauthenticated, remote attacker to conduct a cross-site request forgery (CSRF) attack on an affected system. The vulnerability is due to insufficient CSRF protections for the web-based management interface on an affected device. An attacker could exploit this vulnerability by persuading a user of the interface to follow a malicious link. A successful exploit could allow the attacker to perform arbitrary actions with the privilege level of the affected user. If the user has administrative privileges, the attacker could alter the configuration of, extract information from, or reload an affected device.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Adaptive Security Appliance (ASA) Software | before 9.4.4.34; before 9.6.4.25; before 9.8.4; before 9.9.2.50; before 9.10.1.17 | 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17 | Patch available | CNA |
- Cisco Adaptive Security Appliance (ASA) Software VendorCisco Affected before 9.4.4.34; before 9.6.4.25; before 9.8.4; before 9.9.2.50; before 9.10.1.17 Fixed in 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17 Patch available CNA
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | before 9.4.4.34 | Vulnerable | Cisco |
| cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5505:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5512-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5515-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5520:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5540:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:a:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions before 9.4.4.34 Vulnerable ·Cisco
- cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5505:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5512-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5515-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5520:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5540:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5585-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:h:cisco:asa_5550:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5580:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5585-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco Adaptive Security Appliance (ASA) Software (Cisco) Fixed in 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Adaptive Security Appliance (ASA) Software 9.10.1.17, 9.4.4.34 and 3 more versions
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2019-01320 Improper input validation in Cisco Adaptive Security Appliance SoftwarePriority MEDIUM 48
- TI-2019-01331 Cisco Adaptive Security Appliance Software VPN Denial of Service VulnerabilityPriority LOW 36
- TI-2019-01319 Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software WebVPN Denial of Service VulnerabilityPriority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1713
- 2026-10-03 Alias added: GHSA-c2vh-w5p4-hr7q
References
More Cisco Adaptive Security Appliance Software vulnerabilities
- TI-2025-14628 Buffer overflow in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.9
- TI-2016-05454 Buffer overflow in Cisco Adaptive Security Appliance (ASA) Software through 9.4.2.3 on… KEVCVSS 3.1HIGH 8.8
- TI-2023-06973 Authentication bypass in Cisco Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.1
- TI-2026-82192 Denial of service in Cisco Secure Firewall ASA and FTD SSL VPN KEVCVSS 3.1HIGH 8.6
- TI-2026-16533 Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense… KEVCVSS 3.1HIGH 8.6
- TI-2025-14657 Missing authorization in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1HIGH 8.6
Sources
- CVE-2019-1713 · CVE Program
- CVE-2019-1713 · NVD
- FIRST EPSS
- GHSA-c2vh-w5p4-hr7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences