Cisco Adaptive Security Appliance Software VPN Denial of Service Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-404.
Summary
A vulnerability in the remote access VPN session manager of Cisco Adaptive Security Appliance (ASA) Software could allow a unauthenticated, remote attacker to cause a denial of service (DoS) condition on the remote access VPN services. The vulnerability is due to an issue with the remote access VPN session manager. An attacker could exploit this vulnerability by requesting an excessive number of remote access VPN sessions. An exploit could allow the attacker to cause a DoS condition.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Adaptive Security Appliance (ASA) Software | before 9.4.4.34; before 9.6.4.25; before 9.8.4; before 9.9.2.50; before 9.10.1.17 | 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17 | Patch available | CNA |
- Cisco Adaptive Security Appliance (ASA) Software VendorCisco Affected before 9.4.4.34; before 9.6.4.25; before 9.8.4; before 9.9.2.50; before 9.10.1.17 Fixed in 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* | 9.4 to before 9.4.4.34; 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5506h-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*:*:*:*:* Versions 9.4 to before 9.4.4.34; 9.5 to before 9.6.4.25; 9.7 to before 9.8.4; 9.9 to before 9.9.2.50; 9.10 to before 9.10.1.17 Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5506h-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5525-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5545-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:asa_5555-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco Adaptive Security Appliance (ASA) Software (Cisco) Fixed in 9.4.4.34, 9.6.4.25, 9.8.4, 9.9.2.50, 9.10.1.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Adaptive Security Appliance (ASA) Software 9.10.1.17, 9.4.4.34 and 3 more versions
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2019-01320 Improper input validation in Cisco Adaptive Security Appliance SoftwarePriority MEDIUM 48
- TI-2019-01339 Cisco Adaptive Security Appliance Software Cross-Site Request Forgery VulnerabilityPriority MEDIUM 40
- TI-2019-01319 Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software WebVPN Denial of Service VulnerabilityPriority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1705
- 2026-10-03 Alias added: GHSA-3p9x-fj5f-w25c
References
More Cisco Adaptive Security Appliance Software vulnerabilities
- TI-2025-14628 Buffer overflow in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.9
- TI-2016-05454 Buffer overflow in Cisco Adaptive Security Appliance (ASA) Software through 9.4.2.3 on… KEVCVSS 3.1HIGH 8.8
- TI-2023-06973 Authentication bypass in Cisco Adaptive Security Appliance Software KEVCVSS 3.1CRITICAL 9.1
- TI-2026-82192 Denial of service in Cisco Secure Firewall ASA and FTD SSL VPN KEVCVSS 3.1HIGH 8.6
- TI-2026-16533 Cisco Secure Firewall Adaptive Security Appliance and Secure Firewall Threat Defense… KEVCVSS 3.1HIGH 8.6
- TI-2025-14657 Missing authorization in Cisco Secure Firewall Adaptive Security Appliance Software KEVCVSS 3.1HIGH 8.6
Sources
- CVE-2019-1705 · CVE Program
- CVE-2019-1705 · NVD
- FIRST EPSS
- GHSA-3p9x-fj5f-w25c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences