Path traversal in Atlassian Confluence Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
There was a local file disclosure vulnerability in Confluence Server and Confluence Data Center via page exporting. An attacker with permission to editing a page is able to exploit this issue to read arbitrary file on the server under <install-directory>/confluence/WEB-INF directory, which may contain configuration files used for integrating with other services, which could potentially leak credentials or other sensitive information such as LDAP credentials. The LDAP credential will be potentially leaked only if the Confluence server is configured to use LDAP as user repository. All versions of Confluence Server from 6.1.0 before 6.6.16 (the fixed version for 6.6.x), from 6.7.0 before 6.13.7 (the fixed version for 6.13.x), and from 6.14.0 before 6.15.8 (the fixed version for 6.15.x) are affected by this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Server | 6.1.0 and later; before 6.6.16; 6.7.0 and later; before 6.13.7; 6.14.0 and later; before 6.15.8 | 6.6.16, 6.13.7, 6.15.8 | Patch available | CNA |
- Confluence Server VendorAtlassian Affected 6.1.0 and later; before 6.6.16; 6.7.0 and later; before 6.13.7; 6.14.0 and later; before 6.15.8 Fixed in 6.6.16, 6.13.7, 6.15.8 Patch available CNA
Remediation
- Fix · CNA Confluence Server (Atlassian) Fixed in 6.6.16, 6.13.7, 6.15.8
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3394
- 2026-10-03 Alias added: GHSA-3qjw-wqhv-r92w
References
More Atlassian Confluence vulnerabilities
- TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
- TI-2015-06919 Atlassian Confluence before 5.8.17 allows remote authenticated users to read… CVSS 3.0MEDIUM 4.3
- TI-2019-02553 Server-side request forgery in Atlassian Confluence Server CVSS 3.0CRITICAL 9.8
- TI-2019-14640 Uncontrolled search path in Atlassian Confluence Data Center CVSS 3.1HIGH 7.8
- TI-2019-11192 There was a man-in-the-middle (MITM) vulnerability present in the Confluence Previews… CVSS 3.1MEDIUM 6.5
- TI-2016-05378 Cross-site scripting (XSS) vulnerability in Atlassian Confluence before 5.10.6 allows… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2019-3394 · CVE Program
- CVE-2019-3394 · NVD
- FIRST EPSS
- GHSA-3qjw-wqhv-r92w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences