Uncontrolled search path in Atlassian Confluence Data Center
Priority LOW 35CWE-427Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-427.
Summary
The usage of Tomcat in Confluence on the Microsoft Windows operating system before version 7.0.5, and from version 7.1.0 before version 7.1.1 allows local system attackers who have permission to write a DLL file in a directory in the global path environmental variable variable to inject code & escalate their privileges via a DLL hijacking vulnerability.
Why it matters now
EPSS 0.0048 41st percentileScored 2026-11-07
Fix Fixed Confluence Data Center (Atlassian): 7.0.5, 7.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | before 7.0.5; 7.1.0 and later; before 7.1.1 | 7.0.5, 7.1.1 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected before 7.0.5; 7.1.0 and later; before 7.1.1 Fixed in 7.0.5, 7.1.1 Patch available CNA
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in 7.0.5, 7.1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-20406
- 2026-10-03 Alias added: GHSA-gw5q-m62q-j9vf
References
More Atlassian Confluence vulnerabilities
- TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
- TI-2015-06919 Atlassian Confluence before 5.8.17 allows remote authenticated users to read… CVSS 3.0MEDIUM 4.3
- TI-2019-02553 Server-side request forgery in Atlassian Confluence Server CVSS 3.0CRITICAL 9.8
- TI-2019-02552 Path traversal in Atlassian Confluence Server CVSS 3.0HIGH 8.8
- TI-2019-11192 There was a man-in-the-middle (MITM) vulnerability present in the Confluence Previews… CVSS 3.1MEDIUM 6.5
- TI-2016-05378 Cross-site scripting (XSS) vulnerability in Atlassian Confluence before 5.10.6 allows… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2019-20406 · CVE Program
- CVE-2019-20406 · NVD
- FIRST EPSS
- GHSA-gw5q-m62q-j9vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences