Server-side request forgery in Atlassian Confluence Server
Priority MEDIUM 52CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
The WebDAV endpoint in Atlassian Confluence Server and Data Center before version 6.6.7 (the fixed version for 6.6.x), from version 6.7.0 before 6.8.5 (the fixed version for 6.8.x), and from version 6.9.0 before 6.9.3 (the fixed version for 6.9.x) allows remote attackers to send arbitrary HTTP and WebDAV requests from a Confluence Server or Data Center instance via Server-Side Request Forgery.
Why it matters now
EPSS 0.06712 93rd percentileScored 2026-11-07
Fix Fixed Confluence Server (Atlassian): 6.6.7, 6.8.5, 6.9.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Server | before 6.6.7; 6.7.0 and later; up to 6.7.3; 6.8.0 and later; before 6.8.5; 6.9.0 and later; before 6.9.3 | 6.6.7, 6.8.5, 6.9.3 | Patch available | CNA |
- Confluence Server VendorAtlassian Affected before 6.6.7; 6.7.0 and later; up to 6.7.3; 6.8.0 and later; before 6.8.5; 6.9.0 and later; before 6.9.3 Fixed in 6.6.7, 6.8.5, 6.9.3 Patch available CNA
Remediation
- Fix · CNA Confluence Server (Atlassian) Fixed in 6.6.7, 6.8.5, 6.9.3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3395
- 2026-10-03 Alias added: GHSA-63p3-c254-6c5g
References
More Atlassian Confluence vulnerabilities
- TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
- TI-2015-06919 Atlassian Confluence before 5.8.17 allows remote authenticated users to read… CVSS 3.0MEDIUM 4.3
- TI-2019-02552 Path traversal in Atlassian Confluence Server CVSS 3.0HIGH 8.8
- TI-2019-14640 Uncontrolled search path in Atlassian Confluence Data Center CVSS 3.1HIGH 7.8
- TI-2019-11192 There was a man-in-the-middle (MITM) vulnerability present in the Confluence Previews… CVSS 3.1MEDIUM 6.5
- TI-2016-05378 Cross-site scripting (XSS) vulnerability in Atlassian Confluence before 5.10.6 allows… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2019-3395 · CVE Program
- CVE-2019-3395 · NVD
- FIRST EPSS
- GHSA-63p3-c254-6c5g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences