Read the docs
TI-2019-02554 Aliases CVE-2019-3396GHSA-fr34-8fhg-2m6q

Path traversal in Atlassian Confluence Server

Priority CRITICAL 100Exploited in the wildCWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

Why it matters now

Exploitation Active In CISA KEV since 2021-11-03CISA due date 2022-05-03Known ransomware use
EPSS 0.99913 99th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD and the CNA
Fix Fixed Confluence Server (Atlassian): 6.6.12, 6.12.3, 6.13.3 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianConfluence Serverbefore 6.6.12; 6.7.0 and later; before 6.12.3; next of 6.13.0 and later; before 6.13.3; next of 6.14.0 and later; before 6.14.26.6.12, 6.12.3, 6.13.3, 6.14.2Patch availableCNA
  • Confluence Server VendorAtlassian Affected before 6.6.12; 6.7.0 and later; before 6.12.3; next of 6.13.0 and later; before 6.13.3; next of 6.14.0 and later; before 6.14.2 Fixed in 6.6.12, 6.12.3, 6.13.3, 6.14.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*before 6.6.12; 6.7.0 to before 6.12.3; 6.13.0 to before 6.13.3; 6.14.0 to before 6.14.2VulnerableAtlassian
  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions before 6.6.12; 6.7.0 to before 6.12.3; 6.13.0 to before 6.13.3; 6.14.0 to before 6.14.2 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Confluence Server (Atlassian) Fixed in 6.6.12, 6.12.3, 6.13.3, 6.14.2

Timeline

  1. 2021-11-03 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2019-3396
  3. 2026-10-03 Alias added: GHSA-fr34-8fhg-2m6q

References

  • TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-02556 Path traversal in Atlassian Confluence KEVCVSS 3.1HIGH 8.8
See all 48 →

Sources