Incorrect authorization in Atlassian Confluence Data Center
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
All versions of Confluence Data Center and Server are affected by this unexploited vulnerability. This Improper Authorization vulnerability allows an unauthenticated attacker to reset Confluence and create a Confluence instance administrator account. Using this account, an attacker can then perform all administrative actions that are available to Confluence instance administrator leading to - but not limited to - full loss of confidentiality, integrity and availability. Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 1.0.0 | < 1.0.0, >= 7.19.16, >= 8.3.4, >= 8.4.4, >= 8.5.3, >= 8.6.1 | Patch available | CNA |
| Atlassian | Confluence Server | >= 1.0.0 | < 1.0.0, >= 7.19.16, >= 8.3.4, >= 8.4.4, >= 8.5.3, >= 8.6.1 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 1.0.0 Fixed in < 1.0.0, >= 7.19.16, >= 8.3.4, >= 8.4.4, >= 8.5.3, >= 8.6.1 Patch available CNA
- Confluence Server VendorAtlassian Affected >= 1.0.0 Fixed in < 1.0.0, >= 7.19.16, >= 8.3.4, >= 8.4.4, >= 8.5.3, >= 8.6.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | 1.0 to before 7.19.16; 7.20.0 to before 8.3.4; 8.4.0 to before 8.4.4; 8.5.0 to before 8.5.3 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_data_center:8.6.0:*:*:*:*:*:*:* | 8.6.0 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | 1.0 to before 7.19.16; 7.20.0 to before 8.3.4; 8.4.0 to before 8.4.4; 8.5.0 to before 8.5.3 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:8.6.0:*:*:*:*:*:*:* | 8.6.0 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 1.0 to before 7.19.16; 7.20.0 to before 8.3.4; 8.4.0 to before 8.4.4; 8.5.0 to before 8.5.3 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_data_center:8.6.0:*:*:*:*:*:*:* Versions 8.6.0 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 1.0 to before 7.19.16; 7.20.0 to before 8.3.4; 8.4.0 to before 8.4.4; 8.5.0 to before 8.5.3 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:8.6.0:*:*:*:*:*:*:* Versions 8.6.0 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 1.0.0, >= 7.19.16, >= 8.3.4, >= 8.4.4, >= 8.5.3, >= 8.6.1
- Fix · CNA Confluence Server (Atlassian) Fixed in < 1.0.0, >= 7.19.16, >= 8.3.4, >= 8.4.4, >= 8.5.3, >= 8.6.1
Timeline
- 2023-11-07 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2023-22518
- 2026-10-03 Alias added: GHSA-8prx-84h6-4fr5
References
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2024-14399 Code injection in Atlassian Confluence Data Center CVSS 3.1HIGH 8.8
Sources
- CVE-2023-22518 · CVE Program
- CVE-2023-22518 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-8prx-84h6-4fr5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences