Injection in Atlassian Confluence Data Center
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A template injection vulnerability on older versions of Confluence Data Center and Server allows an unauthenticated attacker to achieve RCE on an affected instance. Customers using an affected version must take immediate action. Most recent supported versions of Confluence Data Center and Server are not affected by this vulnerability as it was ultimately mitigated during regular version updates. However, Atlassian recommends that customers take care to install the latest version to protect their instances from non-critical vulnerabilities outlined in Atlassian’s January Security Bulletin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Confluence Data Center | >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.5.1; >= 8.5.2; >= 8.5.3 | < 8.0.0, >= 8.5.4, >= 8.6.0, >= 8.7.1 | Patch available | CNA |
| Atlassian | Confluence Server | >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.5.1; >= 8.5.2; >= 8.5.3 | < 8.0.0, >= 8.5.4, >= 8.6.0 | Patch available | CNA |
- Confluence Data Center VendorAtlassian Affected >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.5.1; >= 8.5.2; >= 8.5.3 Fixed in < 8.0.0, >= 8.5.4, >= 8.6.0, >= 8.7.1 Patch available CNA
- Confluence Server VendorAtlassian Affected >= 8.0.0; >= 8.1.0; >= 8.2.0; >= 8.3.0; >= 8.4.0; >= 8.5.0; >= 8.5.1; >= 8.5.2; >= 8.5.3 Fixed in < 8.0.0, >= 8.5.4, >= 8.6.0 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* | 8.0.0 to before 8.5.4 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_data_center:8.7.0:*:*:*:*:*:*:* | 8.7.0 | Vulnerable | Atlassian |
| cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* | 8.0.0 to before 8.5.4 | Vulnerable | Atlassian |
- cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.5.4 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_data_center:8.7.0:*:*:*:*:*:*:* Versions 8.7.0 Vulnerable ·Atlassian
- cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.5.4 Vulnerable ·Atlassian
Remediation
- Fix · CNA Confluence Data Center (Atlassian) Fixed in < 8.0.0, >= 8.5.4, >= 8.6.0, >= 8.7.1
- Fix · CNA Confluence Server (Atlassian) Fixed in < 8.0.0, >= 8.5.4, >= 8.6.0
Timeline
- 2024-01-24 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2023-22527
- 2026-10-03 Alias added: GHSA-w64x-j9r3-q79q
References
Exploit 2
More Atlassian Confluence Data Center vulnerabilities
- TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09596 Expression language injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
- TI-2024-14399 Code injection in Atlassian Confluence Data Center CVSS 3.1HIGH 8.8
Sources
- CVE-2023-22527 · CVE Program
- CVE-2023-22527 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-w64x-j9r3-q79q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences