Read the docs
TI-2022-09596 Aliases CVE-2022-26134GHSA-653m-wpjp-54c4

Expression language injection in Atlassian Confluence Data Center

Priority CRITICAL 100Exploited in the wildCWE-917Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-917.

Summary

In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are from 1.3.0 before 7.4.17, from 7.13.0 before 7.13.7, from 7.14.0 before 7.14.3, from 7.15.0 before 7.15.2, from 7.16.0 before 7.16.4, from 7.17.0 before 7.17.4, and from 7.18.0 before 7.18.1.

Why it matters now

Exploitation Active In CISA KEV since 2022-06-02CISA due date 2022-06-06Known ransomware use
EPSS 0.99999 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Confluence Data Center (Atlassian): 7.4.17, 7.13.7, 7.14.3 +4Confluence Server (Atlassian): 7.4.17, 7.13.7, 7.14.3 +4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AtlassianConfluence Data Centernext of 1.3.0 and later; before 7.4.17; 7.13.0 and later; before 7.13.7; 7.14.0 and later; before 7.14.3; 7.15.0 and later; before 7.15.2; 7.16.0 and later; before 7.16.4; 7.17.0 and later; before 7.17.4; 7.18.0 and later; before 7.18.17.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1Patch availableCNA
AtlassianConfluence Servernext of 1.3.0 and later; before 7.4.17; 7.13.0 and later; before 7.13.7; 7.14.0 and later; before 7.14.3; 7.15.0 and later; before 7.15.2; 7.16.0 and later; before 7.16.4; 7.17.0 and later; before 7.17.4; 7.18.0 and later; before 7.18.17.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1Patch availableCNA
  • Confluence Data Center VendorAtlassian Affected next of 1.3.0 and later; before 7.4.17; 7.13.0 and later; before 7.13.7; 7.14.0 and later; before 7.14.3; 7.15.0 and later; before 7.15.2; 7.16.0 and later; before 7.16.4; 7.17.0 and later; before 7.17.4; 7.18.0 and later; before 7.18.1 Fixed in 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1 Patch available CNA
  • Confluence Server VendorAtlassian Affected next of 1.3.0 and later; before 7.4.17; 7.13.0 and later; before 7.13.7; 7.14.0 and later; before 7.14.3; 7.15.0 and later; before 7.15.2; 7.16.0 and later; before 7.16.4; 7.17.0 and later; before 7.17.4; 7.18.0 and later; before 7.18.1 Fixed in 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1 Patch available CNA

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:*1.3 to before 7.4.17; 7.13.0 to before 7.13.7; 7.14.0 to before 7.14.3; 7.15.0 to before 7.15.2; 7.16.0 to before 7.16.4; 7.17.0 to before 7.17.4VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_data_center:7.18.0:*:*:*:*:*:*:*7.18.0VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:*1.3 to before 7.4.17; 7.13.0 to before 7.13.7; 7.14.0 to before 7.14.3; 7.15.0 to before 7.15.2; 7.16.0 to before 7.16.4; 7.17.0 to before 7.17.4VulnerableAtlassian
cpe:2.3:a:atlassian:confluence_server:7.18.0:*:*:*:*:*:*:*7.18.0VulnerableAtlassian
  • cpe:2.3:a:atlassian:confluence_data_center:*:*:*:*:*:*:*:* Versions 1.3 to before 7.4.17; 7.13.0 to before 7.13.7; 7.14.0 to before 7.14.3; 7.15.0 to before 7.15.2; 7.16.0 to before 7.16.4; 7.17.0 to before 7.17.4 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_data_center:7.18.0:*:*:*:*:*:*:* Versions 7.18.0 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_server:*:*:*:*:*:*:*:* Versions 1.3 to before 7.4.17; 7.13.0 to before 7.13.7; 7.14.0 to before 7.14.3; 7.15.0 to before 7.15.2; 7.16.0 to before 7.16.4; 7.17.0 to before 7.17.4 Vulnerable ·Atlassian
  • cpe:2.3:a:atlassian:confluence_server:7.18.0:*:*:*:*:*:*:* Versions 7.18.0 Vulnerable ·Atlassian

Remediation

  • Fix · CNA Confluence Data Center (Atlassian) Fixed in 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1
  • Fix · CNA Confluence Server (Atlassian) Fixed in 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1

Timeline

  1. 2022-06-02 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2022-26134
  3. 2026-10-03 Alias added: GHSA-653m-wpjp-54c4

References

  • TI-2023-08765 Injection in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-08757 Improper input validation in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-08036 Expression language injection in Atlassian Confluence Server KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
  • TI-2023-08759 Incorrect authorization in Atlassian Confluence Data Center KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-14399 Code injection in Atlassian Confluence Data Center CVSS 3.1HIGH 8.8
See all 38 →

Sources