An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An XSSI (cross-site inclusion) vulnerability in Jupyter Notebook before 5.7.6 allows inclusion of resources on malicious pages when visited by users who are authenticated with a Jupyter server. Access to the content of resources has been demonstrated with Internet Explorer through capturing of error messages, though not reproduced with other browsers. This occurs because Internet Explorer's error messages can include the content of any invalid JavaScript that was encountered.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jupyter-notebook (PyPI) | before 5.7.6 | 5.7.6 | Patch available | GHSA-hhx8-cr55-qcxx |
| — | notebook (PyPI) | before 5.7.6 | 5.7.6 | Patch available | GHSA-hhx8-cr55-qcxx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jupyter-notebook (PyPI) Vendor— Affected before 5.7.6 Fixed in 5.7.6 Patch available GHSA-hhx8-cr55-qcxx
- notebook (PyPI) Vendor— Affected before 5.7.6 Fixed in 5.7.6 Patch available GHSA-hhx8-cr55-qcxx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* | before 5.7.6 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* Versions before 5.7.6 Vulnerable ·jupyterlab
Remediation
- Fix · GHSA-hhx8-cr55-qcxx jupyter-notebook (PyPI) Fixed in 5.7.6 Advisory →
- Fix · GHSA-hhx8-cr55-qcxx notebook (PyPI) Fixed in 5.7.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-9644
- 2026-10-03 Alias added: GHSA-hhx8-cr55-qcxx
References
Advisory 3
Other 4
- https://github.com/jupyter/notebook
- https://github.com/pypa/advisory-database/tree/main/vulns/notebook/PYSEC-2019-159.yaml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UP5RLEES2JBBNSNLBR65XM6PCD4EMF7D
- https://lists.fedoraproject.org/archives/list/[email protected]/message/VMDPJBVXOVO6LYGAT46VZNHH6JKSCURO
More jupyterlab Notebook vulnerabilities
- TI-2021-12464 Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in notebook CVSS 3.1CRITICAL 10.0
- TI-2022-08572 Insertion of Sensitive Information into Log File affects Jupyter Notebook CVSS 3.1HIGH 7.5
- TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
- TI-2018-06323 In Jupyter Notebook before 5.4.1, a maliciously forged notebook file can bypass… CVSS 3.0HIGH 7.8
- TI-2015-06101 The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5… CVSS 2.0MEDIUM 6.8
- TI-2024-14994 Potential authentication and CSRF tokens leak in JupyterLab CVSS 3.1HIGH 7.6
Sources
- CVE-2019-9644 · CVE Program
- CVE-2019-9644 · NVD
- FIRST EPSS
- GHSA-hhx8-cr55-qcxx · GitHub Advisory Database · CC BY 4.0
- CVE-2019-9644 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences