Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in notebook
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Jupyter notebook is a web-based notebook environment for interactive computing. In affected versions untrusted notebook can execute code on load. Jupyter Notebook uses a deprecated version of Google Caja to sanitize user inputs. A public Caja bypass can be used to trigger an XSS when a victim opens a malicious ipynb document in Jupyter Notebook. The XSS allows an attacker to execute arbitrary code on the victim computer using Jupyter APIs.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | notebook | 6.0.0 to before 6.4.1; before 5.7.11 | 6.4.1, 5.7.11 | Patch available | CNA |
| — | notebook (PyPI) | before 5.7.11 | 5.7.11 | Patch available | GHSA-hwvq-6gjx-j797 |
| — | notebook (PyPI) | 6.0.0 to before 6.4.1 | 6.4.1 | Patch available | GHSA-hwvq-6gjx-j797 |
- notebook Vendorjupyterlab Affected 6.0.0 to before 6.4.1; before 5.7.11 Fixed in 6.4.1, 5.7.11 Patch available CNA
- notebook (PyPI) Vendor— Affected before 5.7.11 Fixed in 5.7.11 Patch available GHSA-hwvq-6gjx-j797
- notebook (PyPI) Vendor— Affected 6.0.0 to before 6.4.1 Fixed in 6.4.1 Patch available GHSA-hwvq-6gjx-j797
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* | 5.7.0 to before 5.7.11 | Vulnerable | jupyterlab |
| cpe:2.3:a:jupyter:notebook:6.4.0:*:*:*:*:*:*:* | 6.4.0 | Vulnerable | jupyterlab |
- cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* Versions 5.7.0 to before 5.7.11 Vulnerable ·jupyterlab
- cpe:2.3:a:jupyter:notebook:6.4.0:*:*:*:*:*:*:* Versions 6.4.0 Vulnerable ·jupyterlab
Remediation
- Fix · CNA notebook (jupyter) Fixed in 6.4.1, 5.7.11
- Fix · GHSA-hwvq-6gjx-j797 notebook (PyPI) Fixed in 5.7.11 Advisory →
- Fix · GHSA-hwvq-6gjx-j797 notebook (PyPI) Fixed in 6.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32798
- 2026-10-03 Alias added: GHSA-hwvq-6gjx-j797
References
Advisory 2
More jupyterlab Notebook vulnerabilities
- TI-2022-08572 Insertion of Sensitive Information into Log File affects Jupyter Notebook CVSS 3.1HIGH 7.5
- TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
- TI-2018-06323 In Jupyter Notebook before 5.4.1, a maliciously forged notebook file can bypass… CVSS 3.0HIGH 7.8
- TI-2015-06101 The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5… CVSS 2.0MEDIUM 6.8
- TI-2024-14994 Potential authentication and CSRF tokens leak in JupyterLab CVSS 3.1HIGH 7.6
- TI-2024-29399 HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering CVSS 3.1HIGH 7.6
Sources
- CVE-2021-32798 · CVE Program
- CVE-2021-32798 · NVD
- FIRST EPSS
- GHSA-hwvq-6gjx-j797 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences