Potential authentication and CSRF tokens leak in JupyterLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. Users of JupyterLab who click on a malicious link may get their `Authorization` and `XSRFToken` tokens exposed to a third party when running an older `jupyter-server` version. JupyterLab versions 4.1.0b2, 4.0.11, and 3.6.7 are patched. No workaround has been identified, however users should ensure to upgrade `jupyter-server` to version 2.7.2 or newer which includes a redirect vulnerability fix.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyterlab | before 3.6.7; 4.0.0 to before 4.0.11 | 3.6.7, 4.0.11 | Patch available | CNA |
| — | jupyterlab (PyPI) | 4.0.0 to before 4.0.11 | 4.0.11 | Patch available | GHSA-44cc-43rp-5947 |
| — | jupyterlab (PyPI) | before 3.6.7 | 3.6.7 | Patch available | GHSA-44cc-43rp-5947 |
| — | notebook (PyPI) | 7.0.0 to before 7.0.7 | 7.0.7 | Patch available | GHSA-44cc-43rp-5947 |
- jupyterlab Vendorjupyterlab Affected before 3.6.7; 4.0.0 to before 4.0.11 Fixed in 3.6.7, 4.0.11 Patch available CNA
- jupyterlab (PyPI) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-44cc-43rp-5947
- jupyterlab (PyPI) Vendor— Affected before 3.6.7 Fixed in 3.6.7 Patch available GHSA-44cc-43rp-5947
- notebook (PyPI) Vendor— Affected 7.0.0 to before 7.0.7 Fixed in 7.0.7 Patch available GHSA-44cc-43rp-5947
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* | before 3.6.7; 4.0.0 to before 4.0.11 | Vulnerable | jupyterlab |
| cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* | 7.0.0 to before 7.0.7 | Vulnerable | jupyterlab |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
- cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions before 3.6.7; 4.0.0 to before 4.0.11 Vulnerable ·jupyterlab
- cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.0.7 Vulnerable ·jupyterlab
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA jupyterlab (jupyterlab) Fixed in 3.6.7, 4.0.11
- Fix · GHSA-44cc-43rp-5947 jupyterlab (PyPI) Fixed in 4.0.11 Advisory →
- Fix · GHSA-44cc-43rp-5947 jupyterlab (PyPI) Fixed in 3.6.7 Advisory →
- Fix · GHSA-44cc-43rp-5947 notebook (PyPI) Fixed in 7.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22421
- 2026-10-03 Alias added: GHSA-44cc-43rp-5947
References
Advisory 3
Other 4
- https://github.com/jupyterlab/jupyterlab/commit/1ef7a4fa0202ebdf663e1cc0b45c8813a34a0b96
- https://github.com/jupyterlab/jupyterlab/commit/fccd83dc4441da0384ee3fd1322c3b2d9ad4caaa
- https://github.com/jupyterlab/jupyterlab
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UQJKNRDRFMKGVRIYNNN6CKMNJDNYWO2H
More Jupyterlab vulnerabilities
- TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
- TI-2026-30579 Improper input validation in jupyterlab CVSS 3.1HIGH 8.8
- TI-2021-12463 JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> CVSS 3.1CRITICAL 9.6
- TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
- TI-2024-29399 HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering CVSS 3.1HIGH 7.6
- TI-2024-14993 Stored cross site scripting in Markdown Preview in JupyterLab CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-22421 · CVE Program
- CVE-2024-22421 · NVD
- FIRST EPSS
- GHSA-44cc-43rp-5947 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences