Read the docs
TI-2019-07629 Aliases CVE-2019-10320GHSA-xm94-9jw8-p6hw

Information disclosure in Jenkins Credentials Plugin

Priority LOW 22CWE-538Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 2 fixed, 4 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.

Summary

Jenkins Credentials Plugin 2.1.18 and earlier allowed users with permission to create or update credentials to confirm the existence of files on the Jenkins master with an attacker-specified path, and obtain the certificate content of files containing a PKCS#12 certificate.

Why it matters now

EPSS 0.0097 62nd percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins:credentials (Maven): 2.1.19Red Hat: 1 advisoryRed Hat: 2 fixed, 4 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Credentials Pluginup to 2.1.18—No fix listedCNA
—org.jenkins-ci.plugins:credentials (Maven)before 2.1.192.1.19Patch availableGHSA-xm94-9jw8-p6hw
  • Jenkins Credentials Plugin VendorJenkins Affected up to 2.1.18 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected before 2.1.19 Fixed in 2.1.19 Patch available GHSA-xm94-9jw8-p6hw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:*up to 2.1.18VulnerableJenkins
  • cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* Versions up to 2.1.18 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-xm94-9jw8-p6hw org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.1.19 Advisory →

Red Hat 1 advisory

  • RHSA-2019:1636 Released 2019-07-03 · Red Hat rating Important
    OpenShift Container Platform 4.1 jenkins-2-plugins security update
    • Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins-4.1.1561471763-1.el7

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.6AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.7AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.9AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.11Fixed—
Red Hat OpenShift Container Platform 4.1Fixed RHSA-2019:1636

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10320
  2. 2026-10-03 Alias added: GHSA-xm94-9jw8-p6hw

References

  • TI-2022-11602 Cross-site scripting in Jenkins Credentials Plugin CVSS 3.1MEDIUM 5.4
  • TI-2021-04728 Cross-site scripting in Jenkins Credentials Plugin CVSS 3.1MEDIUM 6.1
  • TI-2024-32073 Insufficiently protected credentials in Jenkins Credentials Plugin CVSS 3.1HIGH 7.5

Sources