Read the docs
TI-2021-04728 Aliases CVE-2021-21648GHSA-gchq-9r68-6jwv

Cross-site scripting in Jenkins Credentials Plugin

Priority MEDIUM 41CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 1 fixed, 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability.

Why it matters now

EPSS 0.11308 96th percentileScored 2026-11-07
Fix Partial Jenkins Credentials Plugin (Jenkins project): 2.3.0.1, 2.3.7.1, 2.3.14.1 +2org.jenkins-ci.plugins:credentials (Maven): 2.3.19, 2.3.15.1, 2.3.14.1 +3Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Credentials Pluginup to 2.3.182.3.0.1, 2.3.7.1, 2.3.14.1, 2.3.13.1, 2.3.15.1Patch availableCNA
—org.jenkins-ci.plugins:credentials (Maven)2.3.16 to before 2.3.192.3.19Patch availableGHSA-gchq-9r68-6jwv
—org.jenkins-ci.plugins:credentials (Maven)2.3.15 to before 2.3.15.12.3.15.1Patch availableGHSA-gchq-9r68-6jwv
—org.jenkins-ci.plugins:credentials (Maven)2.3.14 to before 2.3.14.12.3.14.1Patch availableGHSA-gchq-9r68-6jwv
—org.jenkins-ci.plugins:credentials (Maven)2.3.8 to before 2.3.13.12.3.13.1Patch availableGHSA-gchq-9r68-6jwv
—org.jenkins-ci.plugins:credentials (Maven)2.3.1 to before 2.3.7.12.3.7.1Patch availableGHSA-gchq-9r68-6jwv
—org.jenkins-ci.plugins:credentials (Maven)before 2.3.0.12.3.0.1Patch availableGHSA-gchq-9r68-6jwv
  • Jenkins Credentials Plugin VendorJenkins Affected up to 2.3.18 Fixed in 2.3.0.1, 2.3.7.1, 2.3.14.1, 2.3.13.1, 2.3.15.1 Patch available CNA
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 2.3.16 to before 2.3.19 Fixed in 2.3.19 Patch available GHSA-gchq-9r68-6jwv
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 2.3.15 to before 2.3.15.1 Fixed in 2.3.15.1 Patch available GHSA-gchq-9r68-6jwv
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 2.3.14 to before 2.3.14.1 Fixed in 2.3.14.1 Patch available GHSA-gchq-9r68-6jwv
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 2.3.8 to before 2.3.13.1 Fixed in 2.3.13.1 Patch available GHSA-gchq-9r68-6jwv
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 2.3.1 to before 2.3.7.1 Fixed in 2.3.7.1 Patch available GHSA-gchq-9r68-6jwv
  • org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected before 2.3.0.1 Fixed in 2.3.0.1 Patch available GHSA-gchq-9r68-6jwv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:*up to 2.3.18VulnerableJenkins
  • cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* Versions up to 2.3.18 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins Credentials Plugin (Jenkins project) Fixed in 2.3.0.1, 2.3.7.1, 2.3.14.1, 2.3.13.1, 2.3.15.1
  • Fix · GHSA-gchq-9r68-6jwv org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.3.19 Advisory →
  • Fix · GHSA-gchq-9r68-6jwv org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.3.15.1 Advisory →
  • Fix · GHSA-gchq-9r68-6jwv org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.3.14.1 Advisory →
  • Fix · GHSA-gchq-9r68-6jwv org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.3.13.1 Advisory →
  • Fix · GHSA-gchq-9r68-6jwv org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.3.7.1 Advisory →
  • Fix · GHSA-gchq-9r68-6jwv org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.3.0.1 Advisory →

Red Hat 1 advisory

  • RHSA-2021:2437 Released 2021-07-27 · Red Hat rating Moderate
    OpenShift Container Platform 4.8.2 packages and security update
    • Red Hat OpenShift Container Platform 4.8 afterburn-5.0.0-1.rhaos4.8.el8, atomic-openshift-service-idler-4.8.0-202106281541.p0.git.39cfc66.assembly.stream.el8, butane-0.12.1-1.rhaos4.8.el8 +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 4.8Fixed RHSA-2021:2437
Not affected: 1 product
  • Red Hat OpenShift Container Platform 4.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-21648
  2. 2026-10-03 Alias added: GHSA-gchq-9r68-6jwv

References

  • TI-2022-11602 Cross-site scripting in Jenkins Credentials Plugin CVSS 3.1MEDIUM 5.4
  • TI-2024-32073 Insufficiently protected credentials in Jenkins Credentials Plugin CVSS 3.1HIGH 7.5
  • TI-2019-07629 Information disclosure in Jenkins Credentials Plugin CVSS 3.0MEDIUM 4.3

Sources