Insufficiently protected credentials in Jenkins Credentials Plugin
Priority MEDIUM 40CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Credentials Plugin 1380.va_435002fa_924 and earlier, except 1371.1373.v4eb_fa_b_7161e9, does not redact encrypted values of credentials using the `SecretBytes` type when accessing item `config.xml` via REST API or CLI.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00591 48th percentileScored 2026-11-07
Fix Fixed Jenkins Credentials Plugin (Jenkins Project): 1371.1373.v4eb_fa_b_7161e9org.jenkins-ci.plugins:credentials (Maven): 1381.v2c3a, 1371.1373.v4eb
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Credentials Plugin | up to 1380.va_435002fa_924 | 1371.1373.v4eb_fa_b_7161e9 | Patch available | CNA |
| — | org.jenkins-ci.plugins:credentials (Maven) | 1372 to before 1381.v2c3a | 1381.v2c3a | Patch available | GHSA-62jv-j4w7-5hh8 |
| — | org.jenkins-ci.plugins:credentials (Maven) | before 1371.1373.v4eb | 1371.1373.v4eb | Patch available | GHSA-62jv-j4w7-5hh8 |
- Jenkins Credentials Plugin VendorJenkins Affected up to 1380.va_435002fa_924 Fixed in 1371.1373.v4eb_fa_b_7161e9 Patch available CNA
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 1372 to before 1381.v2c3a Fixed in 1381.v2c3a Patch available GHSA-62jv-j4w7-5hh8
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected before 1371.1373.v4eb Fixed in 1371.1373.v4eb Patch available GHSA-62jv-j4w7-5hh8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* | before 1371.1373.v4eb_fa_b_7161e9; 1371.vfee6b_095f0a_3 to before 1380.va_435002fa_924 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* Versions before 1371.1373.v4eb_fa_b_7161e9; 1371.vfee6b_095f0a_3 to before 1380.va_435002fa_924 Vulnerable ·Jenkins
Remediation
- Fix · CNA Jenkins Credentials Plugin (Jenkins Project) Fixed in 1371.1373.v4eb_fa_b_7161e9
- Fix · GHSA-62jv-j4w7-5hh8 org.jenkins-ci.plugins:credentials (Maven) Fixed in 1381.v2c3a Advisory →
- Fix · GHSA-62jv-j4w7-5hh8 org.jenkins-ci.plugins:credentials (Maven) Fixed in 1371.1373.v4eb Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-47805
- 2026-10-03 Alias added: GHSA-62jv-j4w7-5hh8
References
More Jenkins Credentials vulnerabilities
- TI-2022-11602 Cross-site scripting in Jenkins Credentials Plugin CVSS 3.1MEDIUM 5.4
- TI-2021-04728 Cross-site scripting in Jenkins Credentials Plugin CVSS 3.1MEDIUM 6.1
- TI-2019-07629 Information disclosure in Jenkins Credentials Plugin CVSS 3.0MEDIUM 4.3
Sources
- CVE-2024-47805 · CVE Program
- CVE-2024-47805 · NVD
- FIRST EPSS
- GHSA-62jv-j4w7-5hh8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences