Cross-site scripting in Jenkins Credentials Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Credentials Plugin | up to 1111.v35a_307992395 | 2.6.1.1, 1074.1076.v39c30cecb_0e2, 1087.1089.v2f1b_9a_b_040e4 | Patch available | CNA |
| — | org.jenkins-ci.plugins:credentials (Maven) | before 2.6.1.1 | 2.6.1.1 | Patch available | GHSA-rvg5-f5fj-mxvg |
| — | org.jenkins-ci.plugins:credentials (Maven) | 2.6.2 to before 1074.1076.v39c30cecb_0e2 | 1074.1076.v39c30cecb_0e2 | Patch available | GHSA-rvg5-f5fj-mxvg |
| — | org.jenkins-ci.plugins:credentials (Maven) | 1087.v16065d268466 to before 1087.1089.v2f1b_9a_b_040e4 | 1087.1089.v2f1b_9a_b_040e4 | Patch available | GHSA-rvg5-f5fj-mxvg |
| — | org.jenkins-ci.plugins:credentials (Maven) | 1105 – 1111.v35a | — | No fix listed | GHSA-rvg5-f5fj-mxvg |
- Jenkins Credentials Plugin VendorJenkins Affected up to 1111.v35a_307992395 Fixed in 2.6.1.1, 1074.1076.v39c30cecb_0e2, 1087.1089.v2f1b_9a_b_040e4 Patch available CNA
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected before 2.6.1.1 Fixed in 2.6.1.1 Patch available GHSA-rvg5-f5fj-mxvg
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 2.6.2 to before 1074.1076.v39c30cecb_0e2 Fixed in 1074.1076.v39c30cecb_0e2 Patch available GHSA-rvg5-f5fj-mxvg
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 1087.v16065d268466 to before 1087.1089.v2f1b_9a_b_040e4 Fixed in 1087.1089.v2f1b_9a_b_040e4 Patch available GHSA-rvg5-f5fj-mxvg
- org.jenkins-ci.plugins:credentials (Maven) Vendor— Affected 1105 – 1111.v35a Fixed in — No fix listed GHSA-rvg5-f5fj-mxvg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* | before 2.6.1.1; 1055.v1346ba467ba1 to before 1074.1076.v39c30cecb_0e2; 1105.vb_4e24a_c78b_81 to before 1112.vc87b_7a_3597f6 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:credentials:*:*:*:*:*:jenkins:*:* Versions before 2.6.1.1; 1055.v1346ba467ba1 to before 1074.1076.v39c30cecb_0e2; 1105.vb_4e24a_c78b_81 to before 1112.vc87b_7a_3597f6 Vulnerable ·Jenkins
Remediation
- Fix · CNA Jenkins Credentials Plugin (Jenkins project) Fixed in 2.6.1.1, 1074.1076.v39c30cecb_0e2, 1087.1089.v2f1b_9a_b_040e4
- Fix · GHSA-rvg5-f5fj-mxvg org.jenkins-ci.plugins:credentials (Maven) Fixed in 2.6.1.1 Advisory →
- Fix · GHSA-rvg5-f5fj-mxvg org.jenkins-ci.plugins:credentials (Maven) Fixed in 1074.1076.v39c30cecb_0e2 Advisory →
- Fix · GHSA-rvg5-f5fj-mxvg org.jenkins-ci.plugins:credentials (Maven) Fixed in 1087.1089.v2f1b_9a_b_040e4 Advisory →
Red Hat 6 advisories
- RHSA-2022:4947 Released 2022-06-17 · Red Hat rating ImportantOpenShift Container Platform 4.6.59 security update
- Red Hat OpenShift Container Platform 4.6 conmon-2:2.0.21-3.rhaos4.6.el7, conmon-2:2.0.21-3.rhaos4.6.el8, cri-o-1.19.7-2.rhaos4.6.git3c20b65.el7 +2
- RHSA-2022:4909 Released 2022-06-10 · Red Hat rating ImportantOpenShift Container Platform 4.7.52 paackages and security update
- Red Hat OpenShift Container Platform 4.7 jenkins-2-plugins-4.7.1652967082-1.el8
- RHSA-2022:2280 Released 2022-05-31 · Red Hat rating ImportantOpenShift Container Platform 3.11.705 security update
- Red Hat OpenShift Container Platform 3.11 atomic-openshift-dockerregistry-3.11.705-1.g0fa231c.el7, jenkins-2-plugins-3.11.1650628887-1.el7
Show 3 more Red Hat advisories
- RHSA-2022:2205 Released 2022-05-18 · Red Hat rating ImportantOpenShift Container Platform 4.9.33 packages and security update
- Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1651754460-1.el8
- RHSA-2022:1600 Released 2022-05-02 · Red Hat rating ModerateOpenShift Container Platform 4.10.12 security update
- Red Hat OpenShift Container Platform 4.10 cri-o-1.23.2-8.rhaos4.10.git8ad5d25.el8, jenkins-2-plugins-4.10.1650890594-1.el8
- RHSA-2022:0871 Released 2022-03-22 · Red Hat rating ImportantOpenShift Container Platform 4.8.35 security update
- Red Hat OpenShift Container Platform 4.8 cri-o-1.21.5-3.rhaos4.8.gitaf64931.el7, cri-o-1.21.5-3.rhaos4.8.gitaf64931.el8, jenkins-2-plugins-4.8.1646993358-1.el8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2022:2280 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2022:1600 |
| Red Hat OpenShift Container Platform 4.6 | Fixed | RHSA-2022:4947 |
| Red Hat OpenShift Container Platform 4.7 | Fixed | RHSA-2022:4909 |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2022:0871 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2022:2205 |
Not affected: 6 products
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4.10
- Red Hat OpenShift Container Platform 4.6
- Red Hat OpenShift Container Platform 4.7
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29036
- 2026-10-03 Alias added: GHSA-rvg5-f5fj-mxvg
References
More Jenkins Credentials vulnerabilities
- TI-2021-04728 Cross-site scripting in Jenkins Credentials Plugin CVSS 3.1MEDIUM 6.1
- TI-2024-32073 Insufficiently protected credentials in Jenkins Credentials Plugin CVSS 3.1HIGH 7.5
- TI-2019-07629 Information disclosure in Jenkins Credentials Plugin CVSS 3.0MEDIUM 4.3
Sources
- CVE-2022-29036 · CVE Program
- CVE-2022-29036 · NVD
- FIRST EPSS
- GHSA-rvg5-f5fj-mxvg · GitHub Advisory Database · CC BY 4.0
- CVE-2022-29036 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences