Missing authorization in Jenkins Pipeline: Shared Groovy Libraries Plugin
Priority LOW 22CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-862.
Summary
A missing permission check in Jenkins Pipeline: Shared Groovy Libraries Plugin 2.14 and earlier allowed users with Overall/Read access to obtain limited information about the content of SCM repositories referenced by global libraries.
Why it matters now
EPSS 0.01213 68th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven): 2.15Red Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Shared Groovy Libraries Plugin | up to 2.14 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) | before 2.15 | 2.15 | Patch available | GHSA-9x5v-8352-244g |
- Jenkins Pipeline: Shared Groovy Libraries Plugin VendorJenkins Affected up to 2.14 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Vendor— Affected before 2.15 Fixed in 2.15 Patch available GHSA-9x5v-8352-244g
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:pipeline\:shared_groovy_libraries:*:*:*:*:*:jenkins:*:* | shared_groovy_libraries | Vulnerable | Jenkins |
| cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* | 3.11 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | Red Hat |
- cpe:2.3:a:jenkins:pipeline\:shared_groovy_libraries:*:*:*:*:*:jenkins:*:* Versions shared_groovy_libraries Vulnerable ·Jenkins
- cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-9x5v-8352-244g org.jenkins-ci.plugins.workflow:workflow-cps-global-lib (Maven) Fixed in 2.15 Advisory →
Red Hat 2 advisories
- RHSA-2019:2662 Released 2019-09-11 · Red Hat rating ImportantRed Hat OpenShift Container Platform 4.1 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins-4.1.1567707934-1.el7
- RHSA-2019:2651 Released 2019-09-04 · Red Hat rating ImportantRed Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update
- Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1566492396-1.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:2651 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2019:2662 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10357
- 2026-10-03 Alias added: GHSA-9x5v-8352-244g
References
Advisory 6
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2019-10357 · CVE Program
- CVE-2019-10357 · NVD
- FIRST EPSS
- GHSA-9x5v-8352-244g · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10357 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences