Protection mechanism failure in Jenkins Script Security Plugin
Priority MEDIUM 47CWE-693Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-693.
Summary
A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.74 and earlier allows attackers with permission to define sandboxed scripts to provide crafted return values or script binding content that can result in arbitrary code execution on the Jenkins controller JVM.
Why it matters now
EPSS 0.02126 82nd percentileScored 2026-11-07
Fix Fixed Jenkins Script Security Plugin (Jenkins project): 1.66.5org.jenkins-ci.plugins:script-security (Maven): 1.75, 1.66.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Script Security Plugin | up to 1.74 | 1.66.5 | Patch available | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | 1.67 to before 1.75 | 1.75 | Patch available | GHSA-ccr8-4xr7-cgj3 |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.66.5 | 1.66.5 | Patch available | GHSA-ccr8-4xr7-cgj3 |
- Jenkins Script Security Plugin VendorJenkins Affected up to 1.74 Fixed in 1.66.5 Patch available CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected 1.67 to before 1.75 Fixed in 1.75 Patch available GHSA-ccr8-4xr7-cgj3
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.66.5 Fixed in 1.66.5 Patch available GHSA-ccr8-4xr7-cgj3
Remediation
- Fix · CNA Jenkins Script Security Plugin (Jenkins project) Fixed in 1.66.5
- Fix · GHSA-ccr8-4xr7-cgj3 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.75 Advisory →
- Fix · GHSA-ccr8-4xr7-cgj3 org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.66.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2279
- 2026-10-03 Alias added: GHSA-ccr8-4xr7-cgj3
References
Advisory 3
More Jenkins Script Security vulnerabilities
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15845 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2024-22597 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.8
- TI-2019-15850 Protection mechanism failure in Jenkins Script Security Plugin CVSS 3.1HIGH 8.8
- TI-2019-15885 A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.55 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2019-07740 Code injection in Jenkins Script Security Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2020-2279 · CVE Program
- CVE-2020-2279 · NVD
- FIRST EPSS
- GHSA-ccr8-4xr7-cgj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences